Bug 146241 - Virtual interfaces such as ifcfg-eth0:1 do not honor ONBOOT=no
Summary: Virtual interfaces such as ifcfg-eth0:1 do not honor ONBOOT=no
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: initscripts   
(Show other bugs)
Version: 3.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-26 11:46 UTC by Marc Andre Luthi
Modified: 2014-03-17 02:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-26 21:39:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marc Andre Luthi 2005-01-26 11:46:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
My virtual interfaces ifcfg-eth1:1 do not honor ONBOOT=no.

With the next config, after a servive network restart eth1:1  is up


# cat ifcfg-eth1
DEVICE=eth1
ONBOOT=yes
BOOTPROTO=static
IPADDR=128.178.156.52
NETMASK=255.255.255.0
GATEWAY=128.178.156.1

cat ifcfg-eth1:1
DEVICE=eth1:1
ONBOOT=NO
BOOTPROTO=static
IPADDR=128.178.156.109
NETMASK=255.255.255.0
HWADDR=00:0C:F1:D6:38:19


Version-Release number of selected component (if applicable):
initscripts-7.31.18.EL-1

How reproducible:
Always

Steps to Reproduce:
1. configure an ethX:X with ONBOOT=no
2. service network restart
3. ifconfig 
    

Actual Results:  Device ethX:X is up 

Expected Results:  Device is down

Additional info:

I found a similare problem at 

http://lists.swelltech.com/pipermail/webmin-devel-archive/2003-September/001033.html

Comment 1 Bill Nottingham 2005-01-26 21:39:43 UTC
They use the (admittedly, not well documented) ONPARENT=(yes|no)


Note You need to log in before you can comment on or make changes to this bug.