Bug 1462553 - No boot after update Kernel 4.11.5 - Nvidia G310M (optimus)
No boot after update Kernel 4.11.5 - Nvidia G310M (optimus)
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
25
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-18 16:30 EDT by Alex. H. F.
Modified: 2017-08-28 05:11 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-26 16:25:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logs with are the same exceptions that I can see before screen comes black. (3.82 KB, text/plain)
2017-07-05 16:11 EDT, Evgeniy O.
no flags Details

  None (edit)
Description Alex. H. F. 2017-06-18 16:30:36 EDT
Description of problem:

Lenovo B560 with NVIDIA G310M, OPTIMUS does not boot after upgrade Kernel 4.11.?
Video does not come up.
Black screen, and no disk activity on very beginning of boot. 
Some times shows msgs like "CPU did not respond during 23s..."

Booting Kernel 4.10.? everything ok. Nvidia GPU OK.

Switching OFF - NVIDIA OPTIMUS at BIOS (using Intel graphics adapter) Kernel boots and everything is fine. But, no NVIDIA!

Nouveau issue after Kernel upgrade (Once again?!?)


Version-Release number of selected component (if applicable):
Kernel 4.11.5

How reproducible:
Always

Steps to Reproduce:
1. Upgrade Kernel from 4.10.? to 4.11.5
2. Boot system
3. ---> Can't boot


Please, give detailed instructions, how to provide boot log-data.
Comment 1 Alex. H. F. 2017-06-26 15:46:24 EDT
Updated to 11.4.6.201, and still same issue.
Comment 2 Alex. H. F. 2017-06-30 14:41:06 EDT
Updated to 11.4.7, no changes.
Comment 3 Evgeniy O. 2017-07-04 15:14:56 EDT
same issue - 11.4.8
Comment 4 Alex. H. F. 2017-07-04 15:31:40 EDT
Thanks. I confirm.

Any idea, on how to get a log from kernel boot-start?
Comment 5 Evgeniy O. 2017-07-05 06:02:42 EDT
No idea. I can see 4-5 messages before screen comes black. But it happens so fast that I can't read them.
I found no log entries in journalctl for this boot. And /var/log/boot.log file does not created.
Comment 6 Alex. H. F. 2017-07-05 12:36:49 EDT
Since maintainers seems to have NO INTEREST on this matter, only thing I can recommend to you, is:

To increase number of installed kernels, so that at least you keep your latest working kernel available to have full featured NVIDIA-graphics.

Or you can switch your NVIDIA-GPU off in BIOS.
This should allow you to boot Kernels 4.11.x, but every NVIDIA feature as:
acceleration
second display
HDMI
etc.

will be NOT AVAILABLE!
Comment 7 Evgeniy O. 2017-07-05 16:11 EDT
Created attachment 1294734 [details]
Logs with are the same exceptions that I can see before screen comes black.

Last log that I can see is 
`[    2.766096] ACPI Error: Method parse/execution failed [\_SB.PCI0.GFX0._DSM] (Node ffff8983c30c5780), AE_AML_PACKAGE_LIMIT (20160422/psparse-542)`
Comment 8 Evgeniy O. 2017-07-05 16:16:21 EDT
This is logs from successful boot. But for unsuccessful boot I see same messages.
Comment 9 Evgeniy O. 2017-07-22 06:02:28 EDT
fedora 26 - nothing changes
Comment 10 A. Galama 2017-07-23 04:33:59 EDT
Same problem here: I updated from Fedora 25 to 26 and when the boot process switches from text mode to graphics mode all I get is a blank screen. Only thing I can do is press the reset button. I have an ATI Radeon HD 5450 if that helps. The system boots when I add "nomodeset" but then it only shows garbage when the X server starts.

Since Fedora 26 is completely unusable for me in this condition I reverted to my F25 backup.

Maybe this but is related to bug 1456197.
Comment 11 Alex. H. F. 2017-07-23 06:09:05 EDT
Hi A. Galama,
I am afraid you have a different problem than we describe here.
Here the kernel cannot even successfully boot!
Not even text can be seen, nor I have kinda a log to paste here.

In your case thou, it looks like as driver issue (nouveau or NVDIA) with the new kernel. This I have seen once before yet.
Maybe you can be able to find other bug-reports that are closer to your case.
Comment 12 Alex. H. F. 2017-08-26 16:25:27 EDT
Hello,

I am back to report that my problem has been solved with Kernel 4.12.8.
Hope all others involved experience the same.

Very boring the fact, that this bug-report hasn't been service by any maintainer.

See you!
Comment 13 Evgeniy O. 2017-08-28 05:11:30 EDT
Hello, Alex!

Actually for me problem is gone since 4.12.5.

But as tradeoff the touchpad stopped working after this update:(

Alex, if you have such problem and you solved it, please mail me. smlinx@gmail.com

(In reply to Alex. H. F. from comment #12)
> Hello,
> 
> I am back to report that my problem has been solved with Kernel 4.12.8.
> Hope all others involved experience the same.
> 
> Very boring the fact, that this bug-report hasn't been service by any
> maintainer.
> 
> See you!

Note You need to log in before you can comment on or make changes to this bug.