Bug 1462561 - NFV SRIOV guide - problem with order of operations installation of tuned-profiles-cpu-partitioning
NFV SRIOV guide - problem with order of operations installation of tuned-prof...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
10.0 (Newton)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sandra McCann
RHOS Documentation Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-18 18:16 EDT by Andreas Karis
Modified: 2017-06-28 15:26 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-28 15:26:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Karis 2017-06-18 18:16:24 EDT
Description of problem:
In the current documentation, there is a problem with order of operations. In the first-boot.sh, the documentation attempts to install tuned-profiles-cpu-partitioning. This will fail because the RHEL registration steps will execute later, during the pre configuration hook. 


Additional info:

As a workaround, one can customize the overcloud image and install tuned-profiles-cpu-partitioning.
Raw

$ cd images
$ cp overcloud-full.qcow2 overcloud-full_backup.qcow2
# use username and password of Activation key and Organisation ID
$ virt-customize -a overcloud-full.qcow2 -v --run-command 'subscription-manager register --username=[username] --password=[password]'
$ virt-customize -a overcloud-full.qcow2 -v --run-command 'subscription-manager  subscribe --pool=<pool id>'
$ virt-customize -a overcloud-full.qcow2 -v --run-command 'subscription-manager repos --disable=* '
$ virt-customize -a overcloud-full.qcow2 -v --run-command 'subscription-manager repos --enable=rhel-7-server-rpms'
$ virt-customize -a overcloud-full.qcow2 -v --run-command 'subscription-manager repos --enable=rhel-7-server-openstack-10-rpms'
$ virt-customize -a overcloud-full.qcow2 -v --run-command 'yum install tuned-profiles-cpu-partitioning -y'
$ virt-customize -a overcloud-full.qcow2 -v --run-command 'subscription-manager unregister'
$ source /home/stack/stackrc
$ openstack overcloud image upload --image-path . --update-existing

Note You need to log in before you can comment on or make changes to this bug.