Bug 1462646 - Modesetting on nvidia-drm ends gnome X11 session
Modesetting on nvidia-drm ends gnome X11 session
Status: NEW
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
26
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-19 03:17 EDT by Aditya Shah
Modified: 2017-06-19 03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Modesetting X log (36.97 KB, text/plain)
2017-06-19 03:17 EDT, Aditya Shah
no flags Details
X log without modesetting (36.97 KB, text/plain)
2017-06-19 03:18 EDT, Aditya Shah
no flags Details

  None (edit)
Description Aditya Shah 2017-06-19 03:17:15 EDT
Created attachment 1289017 [details]
Modesetting X log

Well weird bug. Setting modeset=1 for nvidia-drm causes the gnome-session to immediately exit on X11. The bug is weird because if you boot without modesetting and then reload module with modesetting from Wayland session, and then login to X11 session, everything works fine. But if modesetting is enabled during boot, you can't login to X11 session, as after 1/2 a sec. of entering the password the screen goes black for a moment and you are back on login screen. But now login to Wayland, reload module without modesetting and log back in using X11, you can get in. I tried looking through Xorg.0.log of both crashed and working sessions, both are similar, no discrepancies in either.
Comment 1 Aditya Shah 2017-06-19 03:18 EDT
Created attachment 1289018 [details]
X log without modesetting

Note You need to log in before you can comment on or make changes to this bug.