Bug 1462708 - engine-setup fails on upgrade from 4.1.3-4 to 4.1.3-5
engine-setup fails on upgrade from 4.1.3-4 to 4.1.3-5
Status: CLOSED NOTABUG
Product: ovirt-engine
Classification: oVirt
Component: Frontend.Core (Show other bugs)
4.1.3
Unspecified Unspecified
unspecified Severity high (vote)
: ---
: ---
Assigned To: bugs@ovirt.org
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-19 07:28 EDT by Petr Matyáš
Modified: 2017-07-17 05:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-17 05:10:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine-setup log (233.95 KB, text/plain)
2017-06-19 07:28 EDT, Petr Matyáš
no flags Details

  None (edit)
Description Petr Matyáš 2017-06-19 07:28:36 EDT
Created attachment 1289066 [details]
engine-setup log

Description of problem:
Having webadmin/userportal-debuginfo packages prevents engine-setup to complete update.

Version-Release number of selected component (if applicable):
4.1.3-5

How reproducible:
always

Steps to Reproduce:
1. install 4.1.3-4 with ovirt*debuginfo packages
2. upgrade to 4.1.3-5
3. run engine-setup

Actual results:
setup fails

Expected results:
setup updates debuginfo packages and completes successfully

Additional info:
[ INFO  ] Checking for product updates...
[ ERROR ] Yum [u'ovirt-engine-userportal-debuginfo-4.1.3.2-0.1.el7.noarch requires ovirt-engine-userportal = 4.1.3.2-0.1.el7', u'ovirt-engine-webadmin-portal-debuginfo-4.1.3.2-0.1.el7.noarch requires ovirt-engine-webadmin-portal = 4.1.3.2-0.1.el7']
[ INFO  ] Yum Performing yum transaction rollback
[ ERROR ] Failed to execute stage 'Environment customization': [u'ovirt-engine-userportal-debuginfo-4.1.3.2-0.1.el7.noarch requires ovirt-engine-userportal = 4.1.3.2-0.1.el7', u'ovirt-engine-webadmin-portal-debuginfo-4.1.3.2-0.1.el7.noarch requires ovirt-engine-webadmin-portal = 4.1.3.2-0.1.el7']
[ INFO  ] Stage: Clean up
Comment 1 Sandro Bonazzola 2017-07-17 05:10:22 EDT
Closing as not a bug. debuginfo packages are not provided anymore being debug information now already available without those packages. debuginfo should be removed after the debugging session anyway.

Note You need to log in before you can comment on or make changes to this bug.