Bug 146271 - Segmentation faults updating gcj-dbtool4
Segmentation faults updating gcj-dbtool4
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-26 12:06 EST by Dave Malcolm
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 09:43:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from yum when updating eclipse-ecj (23.85 KB, text/plain)
2005-01-26 12:08 EST, Dave Malcolm
no flags Details

  None (edit)
Description Dave Malcolm 2005-01-26 12:06:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
I tried updating eclipse packages from Rawhide.  Large numbers of
messages of this form were output:
/var/tmp/rpm-tmp.98821: line 1: 31463 Segmentation fault     
gcj-dbtool4 -a /usr/lib/eclipse/eclipse.db $j
/usr/lib/eclipse/`basename $j`.so

I'm attaching a full log.

Running gcj-dbtool4 on its own now segfaults:
[root@cassandra MyDocs]# gcj-dbtool4
Segmentation fault

rpm -qf /usr/bin/gcj-dbtool4
gcc4-java-4.0.0-0.22


Version-Release number of selected component (if applicable):
gcc4-java-4.0.0-0.22

How reproducible:
Didn't try

Steps to Reproduce:
1. yum update eclipse-ecj
    

Additional info:
Comment 1 Dave Malcolm 2005-01-26 12:08:58 EST
Created attachment 110256 [details]
Output from yum when updating eclipse-ecj
Comment 2 Dave Malcolm 2005-01-26 12:14:56 EST
[root@cassandra MyDocs]# gdb gcj-dbtool4
GNU gdb Red Hat Linux (6.1post-1.20040607.41rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and
you are
welcome to change it and/or distribute copies of it under certain
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for
details.
This GDB was configured as "i386-redhat-linux-gnu"...(no debugging
symbols found)...Using host libthread_db library
"/lib/tls/libthread_db.so.1".
 
(gdb) run
Starting program: /usr/bin/gcj-dbtool4
/usr/src/build/473254-i386/BUILD/gdb+dejagnu-20040607/gdb/dwarf2read.c:5000:
internal-error: could not find partial DIE in cache
 
A problem internal to GDB has been detected,
further debugging may prove unreliable.
Quit this debugging session? (y or n) y
Comment 3 Andrew Overholt 2005-01-26 13:38:08 EST
The problem is resolved when you update libgcj4-devel the same release
as gcc4-java.  I guess for now we should maybe have gcc4-java Require
the same %{version}-%{release}?  What do you think, Jakub?
Comment 4 Jakub Jelinek 2005-01-26 13:43:48 EST
Yeah, will add that.  Checked into CVS, will appear next time I build gcc4.
Comment 5 Andrew Overholt 2005-01-27 17:09:11 EST
In the meantime, I'll make sure to rebuild eclipse every time I see
Jakub rebuild gcc4.  David, do you think you could verify that this is
fixed when you're using the same version of libgcj4-devel and gcc4-java?
Comment 6 Andrew Overholt 2005-01-27 17:09:34 EST
Re-assigning to me.
Comment 7 Andrew Overholt 2005-02-02 09:43:43 EST
I'm going to close this NOTABUG.  Just to make sure we're clear, you
need to update libgcj4-devel, libgcj4, and gcc4-java at the same time.

Note You need to log in before you can comment on or make changes to this bug.