Bug 1462782 - [trello RXZJJKAK] istag name is white when other parts become colored by hovering on istag entry in IS page
[trello RXZJJKAK] istag name is white when other parts become colored by hove...
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Peter
XiaochuanWang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-19 10:03 EDT by Xingxing Xia
Modified: 2017-06-21 09:09 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-21 09:09:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Compared-with-registry-console-display (129.64 KB, image/png)
2017-06-20 04:03 EDT, Xingxing Xia
no flags Details
video record of hover in both openshift and registry web console (364.83 KB, application/octet-stream)
2017-06-20 07:21 EDT, Xingxing Xia
no flags Details

  None (edit)
Description Xingxing Xia 2017-06-19 10:03:49 EDT
Description of problem:
istag name is white when other parts become colored by hovering on istag entry in IS page 

Version-Release number of selected component (if applicable):
openshift v3.6.116

How reproducible:
Always

Steps to Reproduce:
1. Create project, create imagestream with istags
2. On imagestream page, hover on an istag entry


Actual results:
2. The istag entry becomes colored except the left istag name keeps white

Expected results:
2. Whole istag entry is totally colored

Additional info:
Comment 1 Peter 2017-06-20 03:16:42 EDT
I'm not sure this is a bug. Andreas is this something that should be changed?
Comment 2 Xingxing Xia 2017-06-20 04:03 EDT
Created attachment 1289479 [details]
Compared-with-registry-console-display

This bug is from https://trello.com/c/RXZJJKAK/608-0-integrate-image-ui-elements-from-atomic-registry-images and tracking point 1 of https://github.com/openshift/origin-web-console/pull/1136#issuecomment-307936248 .

As comparision, attaching a snapshot from atomic registry web console, there the istag name is not white when hovered. Seems openshift web console needs be consistent with atomic registry web console in terms of that.
Comment 3 Andreas Nilsson 2017-06-20 05:53:24 EDT
Xingxing Xia: Can you post a screenshot of how it looks on on hover and without hover? Just to make sure I'm looking at the right thing.
Comment 4 Xingxing Xia 2017-06-20 07:21 EDT
Created attachment 1289587 [details]
video record of hover in both openshift and registry web console

Attaching a video record of hover in both openshift and registry web console. Can see istag name display with/without hover
Comment 5 Peter 2017-06-20 11:53:27 EDT
Registry will be synced up to be the same as whatever goes into openshift web console in the next version. I'll leave it up to Andreas to decide if this needs changing. But it was intentional.
Comment 6 Andreas Nilsson 2017-06-21 08:26:12 EDT
Yes, that is by design. Neither the tag text or background color is supposed to change, and neither the text color in any of the other columns on hover.
I'll keep the feedback in mind if I hear the same from other people, and then we change it, but for now I think we should keep it as it is.

Note You need to log in before you can comment on or make changes to this bug.