Bug 1462843 - build httpd 2.4.26 on F25 from F27 Sources
build httpd 2.4.26 on F25 from F27 Sources
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
25
x86_64 Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Luboš Uhliarik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-19 12:49 EDT by Dominik Kucher
Modified: 2017-06-21 03:07 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-19 19:51:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominik Kucher 2017-06-19 12:49:45 EDT
I have downloaded the httpd-2.4.26 f27 package from koji and rebuild it on F25 
i have build mod_http it is required 

when i update from 2.2.25 and restart the service i become the error:

● httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Mon 2017-06-19 18:33:39 CEST; 15min ago
     Docs: man:httpd.service(8)
  Process: 5449 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=1/FAILURE)
 Main PID: 5449 (code=exited, status=1/FAILURE)

Jun 19 18:33:39 srv.home systemd[1]: Starting The Apache HTTP Server...
Jun 19 18:33:39 srv.home httpd[5449]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:7777
Jun 19 18:33:39 srv.home httpd[5449]: (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:7777
Jun 19 18:33:39 srv.home httpd[5449]: no listening sockets available, shutting down
Jun 19 18:33:39 srv.home httpd[5449]: AH00015: Unable to open logs


My perimissions and my config file works with the 2.4.25 version
Comment 1 Dominik Kucher 2017-06-19 19:51:08 EDT
the problem was my config file i have LISTEN on httpd.conf and ssl.conf written, but on 2.4.25 and previously it works :-)
Comment 2 Joe Orton 2017-06-21 03:07:20 EDT
Yes, there was a regression in recent 2.4.x releases which meant conflicting Listen directives were ignored; this was fixed in 2.4.26.

Note You need to log in before you can comment on or make changes to this bug.