This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1462960 - ISO repository fails with the error "Importer indicated a failed response"
ISO repository fails with the error "Importer indicated a failed response"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp (Show other bugs)
6.2.9
All Linux
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-19 14:34 EDT by Ram Nayan Singh
Modified: 2017-09-22 15:53 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-22 11:43:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ram Nayan Singh 2017-06-19 14:34:23 EDT
Description of problem:ISO repository fails with the error "Importer indicated a failed response" 


Version-Release number of selected component (if applicable):6.2.9


How reproducible:try to sync rhel6.7 iso 


Steps to Reproduce:
1.Log in to Satellite web UI
2.Click on Content --> Red Hat Repository -- > ISO's --->  Red Hat Enterprise Linux Server  --> Red Hat Enterprise Linux 6.7 Server (ISOs)  ---> Red Hat Enterprise Linux 7 Server ISOs x86_64 6.7 ( Select this ISO)
3. Click Content --> Sync Status --- >  Red Hat Enterprise Linux Server -->  Red Hat Enterprise Linux 6 Server ISOs x86_64 6.7 -----> Synchronize now

Actual results:giving error The PULP_MANIFEST file was not in the expected format
 - pulp:repository:CTS-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_6_Server_ISOs_x86_64_6_7
  - pulp:action:sync
  finish_time: '2017-06-19T17:33:41Z'
  _ns: task_status
  start_time: '2017-06-19T17:33:38Z'
  traceback: |
    Traceback (most recent call last):
      File "/usr/lib/python2.7/site-packages/celery/app/trace.py", line 240, in trace_task
        R = retval = fun(*args, **kwargs)
      File "/usr/lib/python2.7/site-packages/pulp/server/async/tasks.py", line 473, in __call__
        return super(Task, self).__call__(*args, **kwargs)
      File "/usr/lib/python2.7/site-packages/pulp/server/async/tasks.py", line 103, in __call__
        return super(PulpTask, self).__call__(*args, **kwargs)
      File "/usr/lib/python2.7/site-packages/celery/app/trace.py", line 437, in __protected_call__
        return self.run(*args, **kwargs)
      File "/usr/lib/python2.7/site-packages/pulp/server/controllers/repository.py", line 812, in sync
        raise pulp_exceptions.PulpExecutionException(_('Importer indicated a failed response'))
    PulpExecutionException: Importer indicated a failed response
  spawned_tasks: []
  progress_report:
    iso_importer:
      error_message: The PULP_MANIFEST file was not in the expected format.

Expected results:sync complete


Additional info:Tried on my environment same issue.
Comment 1 Michael Hrivnak 2017-06-19 14:39:11 EDT
Were you able to find the exact URL of the repository it is accessing?

The best next step is to get that URL, add "PULP_MANIFEST" onto it, and try to retrieve it manually with a tool like curl. If you could find the URL and try that, it would be a big help for us in understanding how to reproduce, and what the nature of the problem is.
Comment 2 Michael Hrivnak 2017-06-19 15:56:59 EDT
From IRC:

<mhrivnak> bbuckingham, jsherrill is there a way for RamSingh to see the feed URL on a RHEL ISO repo?
<bbuckingham> mhrivnak: RamSingh, assuming Satellite 6 and the repo is enabled, should be able to see it from the Satellite 6 ui
<bbuckingham> go to Content -> Products -> [select product] -> [select repository] and will see it as URL
Comment 5 Michael Hrivnak 2017-06-21 15:19:09 EDT
I was able to reproduce this with upstream Pulp 2.10.3
Comment 6 pulp-infra@redhat.com 2017-06-22 14:32:06 EDT
The Pulp upstream bug status is at NEW. Updating the external tracker on this bug.
Comment 7 pulp-infra@redhat.com 2017-06-22 14:32:09 EDT
The Pulp upstream bug priority is at Normal. Updating the external tracker on this bug.
Comment 8 jcallaha 2017-09-22 11:43:01 EDT
I'm not seeing this in Satellite 6.2.12.

Note You need to log in before you can comment on or make changes to this bug.