Bug 1463013 - xdg-desktop-portal segfaults
xdg-desktop-portal segfaults
Status: CLOSED DUPLICATE of bug 1404004
Product: Fedora
Classification: Fedora
Component: xdg-desktop-portal (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: David King
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-19 18:27 EDT by George R. Goffe
Modified: 2017-06-20 00:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-20 00:55:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gziped flat file of parts of /var/log/messages (69.58 KB, application/x-gzip)
2017-06-19 18:27 EDT, George R. Goffe
no flags Details

  None (edit)
Description George R. Goffe 2017-06-19 18:27:25 EDT
Created attachment 1289324 [details]
gziped flat file of parts of /var/log/messages

Description of problem:
I had been upgrading this system and rebooted to the latest kernel and started the kde (plasma) desktop. It did not start properly. In /var/log/messages I found these segfault messages. Enclosed the complete /var/log/messages from this boot.

Version-Release number of selected component (if applicable):
xdg-desktop-portal-0.8-1.fc27.x86_64

How reproducible:
always for now

Steps to Reproduce:
1..xinitrc contains startkde
2.startx to start the kde desktop
3.

Actual results:
desktop does not appear to have completed initialization. background is black, NO menuing is available

Expected results:


Additional info:


[  115.406414] xdg-desktop-por[4653]: segfault at 8 ip 000055b7cabd690a sp 00007fff3f77fd40 error 4 in xdg-desktop-portal[55b7cabc9000+60000]
[  425.740410] PK-Backend[4853]: segfault at 8 ip 00007f32290b6359 sp 00007f3213064c90 error 4 in libpk_backend_dnf.so[7f32290ad000+10000]
Comment 1 David King 2017-06-20 00:55:44 EDT

*** This bug has been marked as a duplicate of bug 1404004 ***

Note You need to log in before you can comment on or make changes to this bug.