Bug 1463071 - nut was not built with SSL support
nut was not built with SSL support
Status: MODIFIED
Product: Fedora
Classification: Fedora
Component: nut (Show other bugs)
26
All All
unspecified Severity high
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-20 00:28 EDT by Jeffrey C. Ollie
Modified: 2017-08-29 20:06 EDT (History)
2 users (show)

See Also:
Fixed In Version: nut-2.7.4-9.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeffrey C. Ollie 2017-06-20 00:28:48 EDT
As you can see below, Nut was not built with SSL support.  I'd prefer that it was linked with OpenSSL, but I'd be happy with NSS as well.

# rpm -q nut
nut-2.7.4-7.fc26.x86_64
# ldd /usr/sbin/upsd
	linux-vdso.so.1 (0x00007ffe94160000)
	libnsl.so.1 => /lib64/libnsl.so.1 (0x00007f9686c11000)
	libwrap.so.0 => /lib64/libwrap.so.0 (0x00007f9686a06000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f96867e7000)
	libc.so.6 => /lib64/libc.so.6 (0x00007f9686416000)
	/lib64/ld-linux-x86-64.so.2 (0x0000557ed9122000)
Comment 1 Michal Hlavinka 2017-06-22 06:12:54 EDT
enabled nss, as openssl with recent api change is not compatible

Note You need to log in before you can comment on or make changes to this bug.