Bug 1463184 - vagrant-libvirt-0.0.40 is available
vagrant-libvirt-0.0.40 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vagrant-libvirt (Show other bugs)
26
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Vít Ondruch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-20 06:55 EDT by Brian J. Murrell
Modified: 2017-06-26 15:11 EDT (History)
9 users (show)

See Also:
Fixed In Version: vagrant-libvirt-0.0.37-5.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1446608
Environment:
Last Closed: 2017-06-26 15:11:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian J. Murrell 2017-06-20 06:55:10 EDT
+++ This bug was initially created as a clone of Bug #1446608 +++

Latest upstream release: 0.0.38
Current version/release in rawhide: 0.0.37-4.fc26
URL: https://github.com/vagrant-libvirt/vagrant-libvirt

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/5783/

--- Additional comment from Upstream Release Monitoring on 2017-04-28 08:24:11 EDT ---

An unexpected error occured creating the scratch build: please report this issue to the-new-hotness issue tracker at https://github.com/fedora-infra/the-new-hotness/issues

--- Additional comment from Upstream Release Monitoring on 2017-04-29 08:21:29 EDT ---

Latest upstream release: 0.0.39
Current version/release in rawhide: 0.0.37-4.fc26
URL: https://github.com/vagrant-libvirt/vagrant-libvirt

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/5783/

--- Additional comment from Upstream Release Monitoring on 2017-04-29 08:21:34 EDT ---

An unexpected error occured creating the scratch build: please report this issue to the-new-hotness issue tracker at https://github.com/fedora-infra/the-new-hotness/issues

--- Additional comment from Upstream Release Monitoring on 2017-04-29 20:22:55 EDT ---

Latest upstream release: 0.0.40
Current version/release in rawhide: 0.0.37-4.fc26
URL: https://github.com/vagrant-libvirt/vagrant-libvirt

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/5783/

--- Additional comment from Upstream Release Monitoring on 2017-04-29 20:23:02 EDT ---

An unexpected error occured creating the scratch build: please report this issue to the-new-hotness issue tracker at https://github.com/fedora-infra/the-new-hotness/issues

--- Additional comment from Brian J. Murrell on 2017-06-15 08:30:55 EDT ---

Does anything happen with these "Upstream Release Monitoring" tickets?

As this ticket says, 0.0.40 of vagrant-libvirt is out.  Can we get updated packages for Fedora 25?

--- Additional comment from Vít Ondruch on 2017-06-15 08:52:11 EDT ---

(In reply to Brian J. Murrell from comment #6)
> Does anything happen with these "Upstream Release Monitoring" tickets?

Of course they are resolved from time to time

> As this ticket says, 0.0.40 of vagrant-libvirt is out.  Can we get updated
> packages for Fedora 25?

I don't typically update stable versions, unless there is specific reason. So could you please elaborate why F25 should be updated? Thx

--- Additional comment from Brian J. Murrell on 2017-06-15 09:00:11 EDT ---

Because 0.0.40 has additional useful features such as:

https://github.com/vagrant-libvirt/vagrant-libvirt/commit/d78d8969098bbe466d8381a90914a799bb563485

Undoubtedly it has bug fixes in it also.

--- Additional comment from Brian J. Murrell on 2017-06-15 10:15:53 EDT ---

And https://github.com/vagrant-libvirt/vagrant-libvirt/commit/59edda86239b4b33d24f809177c4bc7e3036307a

--- Additional comment from Vít Ondruch on 2017-06-16 04:41:05 EDT ---

Thx for elaborating. The former was already part of 0.0.36 while the later is not released yet I am afraid. But I'll consider the update.

--- Additional comment from Brian J. Murrell on 2017-06-16 07:24:54 EDT ---

Alternatively, both patches backport rather easily.  I can attach the backported patches here if you like, since I have already rolled my own 0.0.35 + those two patches and those two features are working just fine.

--- Additional comment from Upstream Release Monitoring on 2017-06-20 06:10:37 EDT ---

vondruch's vagrant-libvirt-0.0.40-1.fc27 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=909809

--- Additional comment from Vít Ondruch on 2017-06-20 06:18:37 EDT ---

(In reply to Brian J. Murrell from comment #11)
> Alternatively, both patches backport rather easily.  I can attach the
> backported patches here if you like, since I have already rolled my own
> 0.0.35 + those two patches and those two features are working just fine.

I rebased vagrant-libvirt in Rawhide, therefore I'm going to close this ticket now. It would be nice if you could open separate ticket for the backports you are referencing above. Thx.


Requesting backport of this to Fedora 26
Comment 1 Fedora Update System 2017-06-20 08:55:49 EDT
vagrant-libvirt-0.0.37-5.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-6606ecebbb
Comment 2 Fedora Update System 2017-06-21 02:23:54 EDT
vagrant-libvirt-0.0.37-5.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-6606ecebbb
Comment 3 Fedora Update System 2017-06-26 15:11:32 EDT
vagrant-libvirt-0.0.37-5.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.