This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 146319 - vfat module option showexec=no not working
vfat module option showexec=no not working
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-26 17:24 EST by Cyril Zlachevsky
Modified: 2015-01-04 17:16 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-07 02:37:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Cyril Zlachevsky 2005-01-26 17:24:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
when I try to mount VFAT partition with showexec=no option, I get message:

Jan 27 00:07:59 warp kernel: FAT: Unrecognized mount option
"showexec=no" or missing value

For example:
[root@warp mnt]# umount /mnt/win
[root@warp mnt]# mount /dev/hdd1 /mnt/win -o showexec=no
mount: wrong fs type, bad option, bad superblock on /dev/hdd1,
       or too many mounted file systems
[root@warp mnt]# mount /dev/hdd1 /mnt/win
[root@warp mnt]# umount /mnt/win


Version-Release number of selected component (if applicable):
kernel-2.6.10-1.741_FC3

How reproducible:
Always

Steps to Reproduce:
mount <DEVICE> <MOUNTPOINT> -o showexec=no
  

Additional info:
Comment 1 Dave Jones 2005-02-01 23:27:00 EST
does it work if you pass -t vfat ?
Comment 2 Cyril Zlachevsky 2005-02-02 06:52:46 EST
(In reply to comment #1)
> does it work if you pass -t vfat ?
> 

not work together (-t vfat and -o showexec=no)
# mount /dev/hdd1 /mnt/win -o showexec=no -t vfat
mount: wrong fs type, bad option, bad superblock on /dev/hdd1,
       or too many mounted file systems
# mount /dev/hdd1 /mnt/win  -t vfat
#(In reply to comment #1)
Comment 3 Cyril Zlachevsky 2005-02-16 05:48:27 EST
I update kernel to 2.6.10-1.766_FC3 but get same behaviour:
# mount /dev/hdd1 /mnt/win -t vfat -o showexec=no
mount: wrong fs type, bad option, bad superblock on /dev/hdd1,
       or too many mounted file systems

in /var/log/messages:
Feb 16 12:45:27 warp kernel: FAT: Unrecognized mount option "showexec=no" or
missing value
Comment 4 Dave Jones 2005-07-15 16:17:08 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 5 Cyril Zlachevsky 2005-07-17 07:53:57 EDT
Bug unfixed:
[root@warp ~]# uname -a
Linux warp.donlink.net 2.6.12-1.1372_FC3 #1 Fri Jul 15 00:59:10 EDT 2005 i686
athlon i386 GNU/Linux
[root@warp ~]# mount /dev/hdd1 /mnt/win -o showexec=no
mount: wrong fs type, bad option, bad superblock on /dev/hdd1,
       or too many mounted file systems
[root@warp ~]# mount /dev/hdd1 /mnt/win
[root@warp ~]# umount /dev/hdd1
Comment 6 Cyril Zlachevsky 2005-07-17 07:55:23 EDT
Jul 17 14:53:15 warp kernel: FAT: Unrecognized mount option "showexec=no" or
missing value
Comment 7 Jeffrey Moyer 2005-10-27 21:31:45 EDT
It seems that you need not specify an argument for the showexec mount option. 
So, you can get away with:

mount /dev/hdd1 /mnt/win -o showexec

and that will do what you want (I believe).  Please give it a try.

Note You need to log in before you can comment on or make changes to this bug.