Bug 1463203 - config_tempest.py fails if glance endpoint SSL+IPv6
config_tempest.py fails if glance endpoint SSL+IPv6
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tempest (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: zstream
: 7.0 (Kilo)
Assigned To: Chandan Kumar
Martin Kopec
: Triaged, ZStream
Depends On: 1442115
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-20 07:28 EDT by Filip Hubík
Modified: 2017-07-12 09:16 EDT (History)
10 users (show)

See Also:
Fixed In Version: openstack-tempest-kilo-20151020.3.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1442115
Environment:
Last Closed: 2017-07-12 09:16:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1557814 None None None 2017-06-20 07:28 EDT
OpenStack gerrit 293195 None None None 2017-06-20 07:28 EDT

  None (edit)
Description Filip Hubík 2017-06-20 07:28:02 EDT
+++ This bug was initially created as a clone of Bug #1442115 +++

Cloned as same bug appeared in OSPd7 deployments:

Description of problem:
config_tempest.py fails to upload image to glance.
This happens when run against Openstack (overcloud) deployed with both SSL and IPv6 enabled using OSPd director 7.

test -e .venv/bin/activate && source .venv/bin/activate\n source ~/keystonerc\n tools/config_tempest.py  --deployer-input ~/ir-tempest-deployer-input.conf  --debug -v --create  identity.uri $OS_AUTH_URL identity.admin_password $OS_PASSWORD scenario.img_dir ~/tempest-dir/etc    volume-feature-enabled.backup false     image.http_image http://rhos-qe-mirror-tlv.usersys.redhat.com/images/cirros-0.3.4-x86_64-uec.tar.gz    identity.region regionOne    orchestration.stack_owner_role heat_stack_owner     --out ~/tempest-dir/etc/tempest.conf

11:11:33 2017-06-19 07:11:26.001 23366 INFO __main__ [-] Reading defaults from file '/home/stack/tempest-dir/etc/default-overrides.conf'
11:11:33 2017-06-19 07:11:26.002 23366 INFO __main__ [-] Adding options from deployer-input file '/home/stack/ir-tempest-deployer-input.conf'
11:11:33 2017-06-19 07:11:26.002 23366 DEBUG __main__ [-] Setting [compute-feature-enabled] console_output = True set tools/config_tempest.py:373
11:11:33 2017-06-19 07:11:26.002 23366 DEBUG __main__ [-] Setting [compute-feature-enabled] attach_encrypted_volume = False set tools/config_tempest.py:373
11:11:33 2017-06-19 07:11:26.002 23366 DEBUG __main__ [-] Setting [object-storage] operator_role = swiftoperator set tools/config_tempest.py:373
11:11:33 2017-06-19 07:11:26.003 23366 DEBUG __main__ [-] Setting [orchestration] stack_owner_role = heat_stack_owner set tools/config_tempest.py:373
11:11:33 2017-06-19 07:11:26.003 23366 DEBUG __main__ [-] Setting [volume] backend1_name = tripleo_iscsi set tools/config_tempest.py:373
11:11:33 2017-06-19 07:11:26.003 23366 DEBUG __main__ [-] Setting [volume-feature-enabled] bootable = true set tools/config_tempest.py:373
11:11:33 2017-06-19 07:11:26.003 23366 DEBUG __main__ [-] Setting [identity] region = regionOne set tools/config_tempest.py:373
11:11:33 2017-06-19 07:11:26.003 23366 DEBUG __main__ [-] Setting [identity] uri = https://[2620:52:0:13b8:5054:ff:fe3e:1]:13000/v2.0 set tools/config_tempest.py:373
11:11:33 2017-06-19 07:11:26.003 23366 DEBUG __main__ [-] Setting [identity] admin_password = YRepDsr6YPhCsHpRVcAM6jFes set tools/config_tempest.py:373
11:11:33 2017-06-19 07:11:26.003 23366 DEBUG __main__ [-] Setting [scenario] img_dir = /home/stack/tempest-dir/etc set tools/config_tempest.py:373
11:11:33 2017-06-19 07:11:26.003 23366 DEBUG __main__ [-] Setting [volume-feature-enabled] backup = false set tools/config_tempest.py:373
11:11:33 2017-06-19 07:11:26.003 23366 DEBUG __main__ [-] Setting [image] http_image = http://rhos-qe-mirror-tlv.usersys.redhat.com/images/cirros-0.3.4-x86_64-uec.tar.gz set tools/config_tempest.py:373
11:11:33 2017-06-19 07:11:26.004 23366 DEBUG __main__ [-] Setting [identity] region = regionOne set tools/config_tempest.py:373
11:11:33 2017-06-19 07:11:26.004 23366 DEBUG __main__ [-] Setting [orchestration] stack_owner_role = heat_stack_owner set tools/config_tempest.py:373
11:11:33 2017-06-19 07:11:26.004 23366 DEBUG __main__ [-] Setting [identity] uri_v3 = https://[2620:52:0:13b8:5054:ff:fe3e:1]:13000/v3 set tools/config_tempest.py:373
11:11:33 2017-06-19 07:11:26.340 23366 DEBUG __main__ [-] Setting [identity] admin_tenant_id = a615ff4b899a426595da783bb671ebb3 set tools/config_tempest.py:373
11:11:33 2017-06-19 07:11:28.487 23366 INFO __main__ [-] Creating user 'demo' with tenant 'demo' and password 'secrete'
11:11:33 2017-06-19 07:11:28.781 23366 DEBUG __main__ [-] User 'admin' was given the 'admin' role in project 'demo' give_role_to_user tools/config_tempest.py:422
11:11:33 2017-06-19 07:11:28.980 23366 DEBUG __main__ [-] User 'demo' was given the 'heat_stack_owner' role in project 'demo' give_role_to_user tools/config_tempest.py:422
11:11:33 2017-06-19 07:11:28.980 23366 INFO __main__ [-] Creating user 'alt_demo' with tenant 'alt_demo' and password 'secrete'
11:11:33 2017-06-19 07:11:29.184 23366 INFO __main__ [-] Creating flavor 'm1.nano'
11:11:33 2017-06-19 07:11:29.878 23366 DEBUG __main__ [-] Setting [compute] flavor_ref = 703c0af4-a516-4bd6-84ab-94559428e899 set tools/config_tempest.py:373
11:11:33 2017-06-19 07:11:30.631 23366 INFO __main__ [-] Creating flavor 'm1.micro'
11:11:33 2017-06-19 07:11:31.338 23366 DEBUG __main__ [-] Setting [compute] flavor_ref_alt = c1a4e7c7-1851-432a-8b8f-74e99f721b26 set tools/config_tempest.py:373
11:11:33 2017-06-19 07:11:32.110 23366 INFO __main__ [-] Creating image 'cirros-0.3.4-x86_64-disk.img'
11:11:33 2017-06-19 07:11:32.111 23366 INFO __main__ [-] Downloading 'http://download.cirros-cloud.net/0.3.4/cirros-0.3.4-x86_64-disk.img' and saving as '/home/stack/tempest-dir/etc/cirros-0.3.1-x86_64-disk.img'
11:11:33 2017-06-19 07:11:40.698 23366 INFO __main__ [-] Uploading image 'cirros-0.3.4-x86_64-disk.img' from '/home/stack/tempest-dir/etc/cirros-0.3.1-x86_64-disk.img'
11:11:33 2017-06-19 07:11:41.075 23366 CRITICAL tempest [-] EndpointNotFound: Endpoint not found
11:11:33 Details: Error finding address for https://[2620:52:0:13b8:5054:ff:fe3e:1]:13292/v2/images/5d0047fc-842b-4afb-851e-292fb3ed93f0/file: [Errno -9] Address family for hostname not supported
11:11:33 2017-06-19 07:11:41.075 23366 TRACE tempest Traceback (most recent call last):
11:11:33 2017-06-19 07:11:41.075 23366 TRACE tempest   File "tools/config_tempest.py", line 742, in <module>
11:11:33 2017-06-19 07:11:41.075 23366 TRACE tempest     main()
11:11:33 2017-06-19 07:11:41.075 23366 TRACE tempest   File "tools/config_tempest.py", line 149, in main
11:11:33 2017-06-19 07:11:41.075 23366 TRACE tempest     args.image_disk_format)
11:11:33 2017-06-19 07:11:41.075 23366 TRACE tempest   File "tools/config_tempest.py", line 534, in create_tempest_images
11:11:33 2017-06-19 07:11:41.075 23366 TRACE tempest     disk_format=disk_format)
11:11:33 2017-06-19 07:11:41.075 23366 TRACE tempest   File "tools/config_tempest.py", line 568, in find_or_upload_image
11:11:33 2017-06-19 07:11:41.075 23366 TRACE tempest     image = _upload_image(client, image_name, image_dest, disk_format)
11:11:33 2017-06-19 07:11:41.075 23366 TRACE tempest   File "tools/config_tempest.py", line 723, in _upload_image
11:11:33 2017-06-19 07:11:41.075 23366 TRACE tempest     client.store_image(image['id'], data)
11:11:33 2017-06-19 07:11:41.075 23366 TRACE tempest   File "/home/stack/tempest-dir/tempest/services/image/v2/json/image_client.py", line 140, in store_image
11:11:33 2017-06-19 07:11:41.075 23366 TRACE tempest     body=data)
11:11:33 2017-06-19 07:11:41.075 23366 TRACE tempest   File "/home/stack/tempest-dir/tempest/common/glance_http.py", line 202, in raw_request
11:11:33 2017-06-19 07:11:41.075 23366 TRACE tempest     return self._http_request(req_url, method, **kwargs)
11:11:33 2017-06-19 07:11:41.075 23366 TRACE tempest   File "/home/stack/tempest-dir/tempest/common/glance_http.py", line 121, in _http_request
11:11:33 2017-06-19 07:11:41.075 23366 TRACE tempest     raise exc.EndpointNotFound(message)
11:11:33 2017-06-19 07:11:41.075 23366 TRACE tempest EndpointNotFound: Endpoint not found
11:11:33 2017-06-19 07:11:41.075 23366 TRACE tempest Details: Error finding address for https://[2620:52:0:13b8:5054:ff:fe3e:1]:13292/v2/images/5d0047fc-842b-4afb-851e-292fb3ed93f0/file: [Errno -9] Address family for hostname not supported
11:11:33 2017-06-19 07:11:41.075 23366 TRACE tempest 

Version-Release number of selected component (if applicable):
Openstack Director 7

Packages:
openstack-tempest-1:kilo-20151020.1.el7ost.noarch

Sample jobs:
https://rhos-qe-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/view/favs/job/phase2-7_director-rhel-7.3-virthost-3cont_1comp-ipv6-vlan-lvm-ssl/18/
https://rhos-qe-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/view/favs/job/phase2-7_director-rhel-7.3-virthost-3cont_1comp-ipv6-vlan-lvm-ssl/17/
Comment 9 errata-xmlrpc 2017-07-12 09:16:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1745

Note You need to log in before you can comment on or make changes to this bug.