Bug 1463206 - qtconsole-4.2.1 fails to show exceptions.
qtconsole-4.2.1 fails to show exceptions.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-qtconsole (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mukundan Ragavan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-20 07:32 EDT by sdh4
Modified: 2018-01-13 18:18 EST (History)
1 user (show)

See Also:
Fixed In Version: python-qtconsole-4.3.1-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-01-13 18:18:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sdh4 2017-06-20 07:32:46 EDT
Description of problem:
qtconsole 4.2.1 fails to show exceptions when a script is run with %run magic

Upstream bugreport: https://github.com/jupyter/qtconsole/issues/140

The problem is fixed in qtconsole 4.3.0 (Bug #1437281)

This is rather problematic for actually using qtconsole because errors and failures get mysteriously masked. 

Upgrading to 4.3.0 (no substantive changes to .spec file) indeed solves the problem.
Comment 1 Mukundan Ragavan 2017-06-20 20:01:54 EDT
Thanks for the report. I will push an update at the earliest.
Comment 2 Fedora Update System 2017-12-29 11:20:43 EST
python-nbconvert-5.3.1-2.fc27 python-qtconsole-4.3.1-1.fc27 spyder-3.2.5-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-24bfe828bd
Comment 3 Fedora Update System 2017-12-29 14:32:19 EST
python-nbconvert-5.3.1-2.fc27, python-qtconsole-4.3.1-1.fc27, spyder-3.2.5-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-24bfe828bd
Comment 4 Fedora Update System 2018-01-04 18:39:04 EST
python-nbconvert-5.3.1-2.fc27 python-qtconsole-4.3.1-1.fc27 spyder-3.2.5-3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-24bfe828bd
Comment 5 Fedora Update System 2018-01-05 06:57:00 EST
python-nbconvert-5.3.1-2.fc27, python-qtconsole-4.3.1-1.fc27, spyder-3.2.5-3.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-24bfe828bd
Comment 6 Fedora Update System 2018-01-13 18:18:35 EST
python-nbconvert-5.3.1-2.fc27, python-qtconsole-4.3.1-1.fc27, spyder-3.2.5-3.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.