Bug 146323 - kernel: smbfs: failed to load nls '866'
kernel: smbfs: failed to load nls '866'
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-26 17:50 EST by Cyril Zlachevsky
Modified: 2015-01-04 17:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 04:18:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cyril Zlachevsky 2005-01-26 17:50:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I get wrong codepage (non 866, non-cyrillic) if try to mount smbfs
filesystem mountpoint with codepage=866 option
In /var/log/messages I get message:

Jan 27 00:41:44 warp kernel: Unable to load NLS charset 866
Jan 27 00:41:44 warp kernel: smbfs: failed to load nls '866'
Jan 27 00:41:44 warp kernel: SELinux: initialized (dev smbfs, type
smbfs), uses genfs_contexts
Jan 27 00:41:44 warp mount.smbfs[7775]: [2005/01/27 00:41:44, 0]
client/smbmount.c:send_fs_socket(406)
Jan 27 00:41:44 warp mount.smbfs[7775]:   mount.smbfs: entering daemon
mode for service \\192.168.134.8\E, pid=7775

Version-Release number of selected component (if applicable):
samba-common-3.0.10-1.fc3
samba-client-3.0.10-1.fc3
samba-3.0.10-1.fc3 
kernel-2.6.10-1.741_FC3

How reproducible:
Always

Steps to Reproduce:
1. smbmount //192.168.134.8/E /mnt/XP -o codepage=866
2. check /var/log/messages and /mnt/XP    

Additional info:
Comment 1 Dave Jones 2005-02-01 23:24:28 EST
can you retry with the -1.753 kernel in updates-testing ?
Comment 2 Cyril Zlachevsky 2005-02-16 05:55:55 EST
I try the -1.766 kernel. This bug in newest kernel present too :(
Comment 3 Dave Jones 2005-07-15 16:47:19 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 4 Cyril Zlachevsky 2005-07-17 08:10:07 EDT
kernel-2.6.12-1.1372_FC3 - bug unfixed:
# smbmount //192.168.134.8/E /mnt/XP -o codepage=866
opts: codepage=866
passthrough options 'codepage=866'
mount.smbfs started (version 3.0.10-1.fc3)
added interface ip=192.168.134.3 bcast=192.168.134.255 nmask=255.255.255.0
Connecting to 192.168.134.8 at port 445
Password:
[root@warp ~]# less /var/log/messages
Jul 17 15:07:50 warp kernel: Unable to load NLS charset 866
Jul 17 15:07:50 warp kernel: smbfs: failed to load nls '866'
Jul 17 15:07:50 warp kernel: SELinux: initialized (dev smbfs, type smbfs), uses
genfs_contexts
Jul 17 15:07:50 warp mount.smbfs[4414]: [2005/07/17 15:07:50, 0]
client/smbmount.c:send_fs_socket(406)
Jul 17 15:07:50 warp mount.smbfs[4414]:   mount.smbfs: entering daemon mode for
service \\192.168.134.8\E, pid=4414
Comment 5 Dave Jones 2005-07-29 20:33:36 EDT
please try with 'codepage=cp866'
Comment 6 Cyril Zlachevsky 2005-09-28 07:33:21 EDT
yes 'codepage=cp866' is worked fine!

Note You need to log in before you can comment on or make changes to this bug.