Bug 1463263 - remove ISO domain creation from OST
remove ISO domain creation from OST
Status: CLOSED CURRENTRELEASE
Product: ovirt-system-tests
Classification: Community
Component: General (Show other bugs)
2.0
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Dafna Ron
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-20 09:03 EDT by Dafna Ron
Modified: 2018-03-20 11:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-20 11:31:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dron: planning_ack?
dron: devel_ack?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 79329 None None None 2017-07-12 08:33 EDT
oVirt gerrit 79342 None None None 2017-07-12 10:48 EDT

  None (edit)
Description Dafna Ron 2017-06-20 09:03:31 EDT
Description of problem:

There's a test that gets stuck on mount to iso domain. 

We have an open bug on this, the mount to the ISO domain gets stuck and never returns:
call mount with (u'192.168.201.3:/exports/nfs/iso', u'/rhev/data-center/mnt/192.168.201.3:_exports_nfs_iso') {'vfstype': 'nfs', 'mntOpts': 'soft,nosharecache,timeo=600,retrans=6,nfsvers=3', 'timeout': None, 'cgroup': None}


since we no longer actually use the iso domain so we should remove this domain from our tests. 

link to failed job: http://jenkins.ovirt.org/job/test-repo_ovirt_experimental_master/7264
Comment 4 Yaniv Kaul 2017-07-10 21:00:21 EDT
I'd begin with skip.
Comment 5 Dafna Ron 2017-07-11 14:50:35 EDT
If I am reading the code correctly, the add secondary domain test is creating more than just the iso domain:

http://pastebin.test.redhat.com/502050

I can't skip the test by adding raise SkipTest without stopping creating the rest of the domains. 

I can comment out the functools.partial(add_iso_storage_domain, prefix), which would disable it but I am not sure this is the correct solution 

any suggestions?
Comment 6 Eyal Edri 2017-07-12 02:43:43 EDT
Can we split the test into multiple tests, so each storage domain would be added it its own test? that way we'll only disable the adding of iso domain?
Comment 7 Yaniv Kaul 2017-07-12 05:32:45 EDT
(In reply to Eyal Edri from comment #6)
> Can we split the test into multiple tests, so each storage domain would be
> added it its own test? that way we'll only disable the adding of iso domain?

We can, but it is slow. Just comment out the call.
Comment 8 Dafna Ron 2017-07-12 07:37:31 EDT
https://gerrit.ovirt.org/#/c/79329/
Comment 9 Eyal Edri 2017-07-12 08:20:04 EDT
Dafna, we use the 'external tracker' to attached oVirt patches to bugs.
Can you use the 'oVirt Gerrit' tracker and attach the fix to the bug?

Note You need to log in before you can comment on or make changes to this bug.