Bug 1463267 - getting_started_with_kubernetes/#kubernetes_and_selinux_permissions refers to bugzilla which was already resolved
getting_started_with_kubernetes/#kubernetes_and_selinux_permissions refers to...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-RHEL-Atomic (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Chris Negus
ecs-bugs
Vikram Goyal
: Documentation, Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-20 09:11 EDT by Jan Pazdziora
Modified: 2017-07-05 11:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-05 11:47:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2017-06-20 09:11:39 EDT
Description of problem:

The section 2.4. Kubernetes and SELinux Permissions of https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux_atomic_host/7/html-single/getting_started_with_kubernetes/#kubernetes_and_selinux_permissions ends with

   BZ#1222060 tracks this issue.

linking https://bugzilla.redhat.com/show_bug.cgi?id=1222060. That bugzilla has been CLOSED NOTABUG a year and a half ago but even with the latest docker versions, the chcon -R needs to be used.

It is not clear what the reader should find in that bugzilla which would help them to have smoother experience.

Version-Release number of selected component (if applicable):

Document https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux_atomic_host/7/html-single/getting_started_with_kubernetes/#kubernetes_and_selinux_permissions as of today.
docker-1.12.6-28.git1398f24.el7.x86_64
kubernetes-node-1.5.2-0.6.gitd33fd89.el7.x86_64

How reproducible:

Deterministic.

Steps to Reproduce:
1. Follow the steps that lead the reader through chcon-ing the directory which is used as PV.
2. Read line pointing to bug 1222060 as additional source of information and something which might resolve the "issue".

Actual results:

The bugzilla is already CLOSED and there is no change in behaviour.

Expected results:

The link to that bugzilla shouldn't be there, or it should point to different bugzilla which would track RFE to (for example) have the hostPath directories chcon-ed automatically.

Additional info:
Comment 2 Micah Abbott 2017-06-20 14:13:52 EDT
moving to docs team
Comment 3 Chris Negus 2017-07-02 13:12:05 EDT
I removed the reference to the bug from the docs.[1] Because this is a procedure that is not supported for production-quality setups anyway, I see no reason not to just tell them how to use chcon manually to set SELinux labels properly. Expect the fixed docs to be published in the next few days:

[1] https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux_atomic_host/7/html-single/getting_started_with_kubernetes/#kubernetes_and_selinux_permissions
Comment 4 Chris Negus 2017-07-05 11:47:49 EDT
Docs are now published.

Note You need to log in before you can comment on or make changes to this bug.