Bug 1463270 - LUA init file in wrong RPM
LUA init file in wrong RPM
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: wireshark (Show other bugs)
26
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Martin Sehnoutka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-20 09:19 EDT by Ulrich Drepper
Modified: 2017-07-21 04:35 EDT (History)
6 users (show)

See Also:
Fixed In Version: wireshark-2.4.0-2.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-21 04:35:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulrich Drepper 2017-06-20 09:19:11 EDT
Description of problem:
Trying to use a LUA dissector fails unless the -devel package is installed

Version-Release number of selected component (if applicable):
wireshark-2.2.7-1.fc26.x86_64

How reproducible:
always

Steps to Reproduce:
1.try using a LUA dissector like https://github.com/whitequark/zmtp-wireshark
2.
3.

Actual results:
Error on startup because of missing ftypes definition

Expected results:
Correct startup and protocol becomes available

Additional info:
The problem is that the file

/usr/share/wireshark/init.lua

is in the -devel package.  This file provides runtime definitions, though.  The file is automatically read on startup when LUA files are used.

The fix is simple: move that file from the -devel package to the base package.

I have seen people reporting the same issue with RHEL7 versions.
Comment 1 Martin Sehnoutka 2017-06-22 07:48:58 EDT
Thanks for a suggestion, but don't you think that using custom dissectors should require devel subpackage? 

Please don't take this the wrong way, I'm willing to do the switch from devel subpackage to the main package, I just need a good reason.
Comment 2 Ulrich Drepper 2017-06-27 03:48:06 EDT
(In reply to Martin Sehnoutka from comment #1)
> Thanks for a suggestion, but don't you think that using custom dissectors
> should require devel subpackage? 

In this case I wasn't developing a custom dissector.  I was deploying one someone else wrote.  I don't think we require the gnome shell development package to be installed to deploy an extension.  Or for browsers.  Or email clients.
Comment 3 Peter Lemenkov 2017-06-27 07:07:15 EDT
(In reply to Martin Sehnoutka from comment #1)
> Thanks for a suggestion, but don't you think that using custom dissectors
> should require devel subpackage? 

I believe it should go into main sub-package. Lua scripts aren't the same as ANSI C header files. These are runtime dependency files. And it looks like they were put into devel accidentally.

Wireshark itself allows scripting. The idea (one of the ideas behind that extension) is to expand wireshark capabilities on the fly, w/o recompiling anything - so these ones aren't devel bits in a traditional "-devel" subpackage meaning.
Comment 4 Martin Sehnoutka 2017-06-28 05:09:17 EDT
Thanks for your responses. I can move the file in Fedora packages.
Comment 5 Martin Sehnoutka 2017-07-21 04:35:54 EDT
Patch:
http://pkgs.fedoraproject.org/cgit/rpms/wireshark.git/commit/?id=7c0782a0ee51fb1faa7c81b0481c54055e800b43

Fixed in: wireshark-2.4.0-2.fc27

Note You need to log in before you can comment on or make changes to this bug.