Bug 146328 - Cups printers are no longer detected
Cups printers are no longer detected
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-26 19:35 EST by Gérard Milmeister
Modified: 2007-11-30 17:10 EST (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-18 10:51:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gérard Milmeister 2005-01-26 19:35:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Galeon/1.3.19

Description of problem:
Cups printers used to be detected by Openoffice 1.1.2.

Now I get only the choice of "Generic Printer".

Version-Release number of selected component (if applicable):
openoffice.org-1.1.3-2.5.fc3

How reproducible:
Always

Steps to Reproduce:
 

Additional info:
Comment 1 Gerry Tool 2005-01-29 22:06:16 EST
I can comfirm that this is also happening to me.
Comment 2 Paul Hooper 2005-01-29 22:41:10 EST
Me also.

openoffice.org-libs-1.1.3-2.5.fc3
cups-1.1.22-0.rc1.8.4
2.6.10-1.741_FC3smp
Comment 3 Tim Jackson 2005-01-31 07:18:32 EST
I have the exact same problem; same versions as above. Don't know if
this is helpful, but running an strace on spadmin does show it
apparently successfully opening libcups, yet the CUPS printers do not
show up either in spadmin or the main OO programs:

$ strace /usr/lib/ooo-1.1/program/spadmin.bin 2>&1|grep cups
open("/usr/lib/ooo-1.1/program/libcups.so.2", O_RDONLY) = -1 ENOENT
(No such file or directory)
open("/usr/lib/ooo-1.1/program/libcups.so.2", O_RDONLY) = -1 ENOENT
(No such file or directory)
open("/usr/lib/ooo-1.1/program/libcups.so.2", O_RDONLY) = -1 ENOENT
(No such file or directory)
open("/usr/lib/libcups.so.2", O_RDONLY) = 19
Comment 4 Matthias Haase 2005-01-31 09:57:40 EST
Same here on two boxes: After upgrade to Openoffice 1.1.3 printing
stops. Using now the command 'lpr -L printername' (together with
generic) as a workaround in order to make the printing working again.
Comment 5 Dan Williams 2005-01-31 10:01:52 EST
Maybe Chris' CUPS patches got whacked in some way in the ooo-build stuff?
Comment 6 Dan Williams 2005-01-31 10:04:00 EST
Diff for cups patch between 1.1.2 and 1.1.3 seems to be these added
patches for 1.1.3:

# Newer psprint (fixes various CUPS bugs)
psprint-m46-to-m62.diff
# default encoding ADOBE_STANDARD is new so revert to MS_1252
psprint-defaultencoding.diff
# revert FONTCONFIG_FONTS change to ENABLE_FONTCONFIG
psprint-fontconfigvar.diff
# revert back to old JDK path detection method
psprint-nojvmfwk.diff
Comment 7 Dan Williams 2005-01-31 10:22:59 EST
So, the M62 psprint code moves the printer discovery to a separate
thread (which is correct since CUPS can take a while to reply and that
would mean OOo taking even longer to start up than it already does).

The problem seems to be that OOo tries to grab results from that
thread too early and never tries again.  Its _supposed_ to try again
when you do File->Print but isn't.

printerinfomanager.cxx:
PrinterInfoManager& PrinterInfoManager::get()
{
    static PrinterInfoManager* pManager = NULL;

    if( ! pManager )
    {
        pManager = CUPSManager::tryLoadCUPS();
        if( ! pManager )
            pManager = new PrinterInfoManager();

        if( pManager )
            pManager->initialize();
    }
    return *pManager;
}

Result being that once called, initialize() never gets called again,
because the pManager object already exists.
Comment 8 Marc Schwartz 2005-02-01 11:59:46 EST
FWIW, as perhaps another me too post, my Okidata printer is listed in
the printer selection dialog, but if selected, nothing goes out to the
printer. 

As others have noted, if I select the generic printer, it does send
output to the printer.

I don't know if that is slightly different behavior or not, but
thought that I would mention it.

openoffice.org-1.1.3-2.5.fc3
Comment 9 Kevin DeKorte 2005-02-01 15:14:24 EST
Only generic printer is listed in the printer dialog. None of my CUPS
printers are listed (ones added via system-config-printer-gui)

FC3
openoffice.org-i18n-1.1.3-2.5.fc3
openoffice.org-1.1.3-2.5.fc3
openoffice.org-kde-1.1.3-2.5.fc3
openoffice.org-libs-1.1.3-2.5.fc3
Comment 10 Eirik Thorsnes 2005-02-01 17:03:23 EST
I see same symptoms. If I start with ooffice --widgets-set
{original,kde} instead of gtk the printer list shows again.
Comment 11 Dan Williams 2005-02-02 09:52:18 EST
Fix for this will be in next build that comes out.  See upstream OOo
bug here:

http://www.openoffice.org/issues/show_bug.cgi?id=37488

Comment 12 Wayne Schuller 2005-02-04 02:03:46 EST
I get this problem too. This regression was particularly frustrating.

pentium system:
openoffice.org-1.1.3-2.5.fc3
openoffice.org-libs-1.1.3-2.5.fc3

Looking forward to the fix...
Comment 13 Kevin DeKorte 2005-02-04 08:38:16 EST
Workaround:

Add

export SAL_USE_VCLPLUGIN=gen

To you .bash_profile scipt and the printers will work, but openoffice
will use it's original widget set. So the colors will be off in the
widgets.
Comment 14 shrek-m 2005-02-06 09:20:45 EST
$ export SAL_USE_VCLPLUGIN=gen
$ /usr/lib/ooo-1.1/program/soffice

openoffice.org-1.1.3-2.5.fc3
thanks, my printers are listed and i can print again.
Comment 15 Dan Williams 2005-02-06 09:34:36 EST
-5 is out for Rawhide already, and building right now for FC-3.  It
fixes this problem and the Calc paste cells problem.
Comment 16 Phil Anderson 2005-02-11 23:05:19 EST
openoffice.org-1.1.3-5.5.0.fc3 fixes the problem for me, however it introduces
bug 147893

Note You need to log in before you can comment on or make changes to this bug.