Bug 146333 - targeted policy 1.17.30-2.74 denies httpd access to home dir on autofs
targeted policy 1.17.30-2.74 denies httpd access to home dir on autofs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-27 00:44 EST by Alexandre Oliva
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 1.17.30-2.75
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-28 11:46:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2005-01-27 00:44:34 EST
/home is controlled by automount at www.lsd.ic.unicamp.br.  /home/lsd
(where my homd dir is) is actually local to the same server, but this
shouldn't matter, I think, since I'm getting avc errors for / and
/home when I try to access http://www.lsd.ic.unicamp.br/~oliva.  My
public_html is actually a soft link into another, server-local
directory, but this shouldn't matter either.

Jan 27 02:04:25 emilia kernel: audit(1106798665.748:0): avc:  denied 
{ search } for  pid=5868 exe=/usr/sbin/httpd name=/ dev=autofs
ino=8490 scontext=root:system_r:httpd_t
tcontext=system_u:object_r:autofs_t tclass=dir
Jan 27 02:04:25 emilia kernel: audit(1106798665.748:0): avc:  denied 
{ getattr
} for  pid=5868 exe=/usr/sbin/httpd path=/home dev=autofs ino=8490
scontext=root:system_r:httpd_t tcontext=system_u:object_r:autofs_t
tclass=dir

The problem is that the bits that would enable httpd to enter autofs_t
dirs are conditional on `automount.te' being defined in apache.te.  I
don't see that automount.te would ever be defined as a macro.  As a
result, apache.te can't enter /home, and things go down the hill from
there.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.17.30-2.74
Comment 1 Daniel Walsh 2005-01-27 10:00:40 EST
Yes this is an invalid check and will be removed.  autofs does not
require automount.te.
Fixed in selinux-policy-targeted-1.17.30-2.75

Could you remove the check from your policy and see if your home dirs
work?

Dan
Comment 2 Alexandre Oliva 2005-01-28 09:51:50 EST
Yes, it does work after removing the bogus ifdef.  I'd actually tested
it like that before posting the bug.  Sorry that I wasn't clear.
Comment 3 Alexandre Oliva 2005-01-30 13:07:37 EST
Confirmed fixed in 1.17.30-2.75, thanks.
Comment 4 Alexandre Oliva 2005-01-30 13:14:31 EST
Err...  Closed this by mistake, it definitely was a bug.  I meant to
leave it open until the testing update became an official update.

Note You need to log in before you can comment on or make changes to this bug.