Bug 146338 - Detached toolbars are immovable
Detached toolbars are immovable
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnumeric (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-27 01:57 EST by Haran Sivakumaran
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-27 09:23:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Haran Sivakumaran 2005-01-27 01:57:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
Under GNOME, when the standard and format toolbars of Gnumeric are
detached and moved, they subsequently become immovable upon re-launch
of Gnumeric, even if "Preferences > Menus & Toolbars > Detachable
toolbars" is set.

I've tried moving them with middle-click-drag, left-click-drag,
right-click-drag, modifier-key-combo-middle-click-drag, etc., etc.,
but nothing seems to work. If I select a toolbar and type ALT+F4, it
disappears. But quiting Gnumeric invokes a "quit unexpectedly" error
and the toolbar reappears when Gnumeric is launched again.

Backtrace from Gnumeric crash follows:

Backtrace was generated from '/usr/bin/gnumeric'

(no debugging symbols found)...Using host libthread_db library
"/lib/tls/libthread_db.so.1".
(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...[Thread debugging using
libthread_db enabled]
[New Thread -1208125760 (LWP 8261)]
(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols
found)...0x00a647a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#0  0x00a647a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x00cca42b in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#2  0x031b1f50 in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x00a647a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#5  0x00aa4955 in raise () from /lib/tls/libc.so.6
#6  0x00aa6319 in abort () from /lib/tls/libc.so.6
#7  0x0021af7e in g_logv () from /usr/lib/libglib-2.0.so.0
#8  0x0021afb0 in g_log () from /usr/lib/libglib-2.0.so.0
#9  0x03119c36 in bonobo_dock_item_unfloat () from
/usr/lib/libbonoboui-2.so.0
#10 0x0311a132 in bonobo_dock_item_set_behavior ()
   from /usr/lib/libbonoboui-2.so.0
#11 0x002923ae in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#12 0x0027a6b2 in g_cclosure_new_swap () from
/usr/lib/libgobject-2.0.so.0
#13 0x0027a347 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#14 0x00290646 in g_signal_has_handler_pending ()
   from /usr/lib/libgobject-2.0.so.0
#15 0x00291cbc in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#16 0x00291f5a in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#17 0x0057db9d in gtk_widget_unrealize () from
/usr/lib/libgtk-x11-2.0.so.0
#18 0x0311486e in bonobo_dock_get_type () from
/usr/lib/libbonoboui-2.so.0
#19 0x00408fc6 in gtk_container_forall () from
/usr/lib/libgtk-x11-2.0.so.0
#20 0x005803b4 in gtk_widget_get_default_direction ()
   from /usr/lib/libgtk-x11-2.0.so.0
#21 0x0057dac8 in gtk_widget_shape_combine_mask ()
   from /usr/lib/libgtk-x11-2.0.so.0

Version-Release number of selected component (if applicable):
gnumeric-1.2.13-10

How reproducible:
Always

Steps to Reproduce:
1. Enable detachable toolbars (GNOME Menu > Preferences > Menus &
Toolbars > [x] Detachable toolbars)
2. Launch Gnumeric, detach a toolbar and move it onto the spreadsheet
3. Quit and restart Gnumeric

Actual Results:  Detached toolbars are immovable and cannot be
dismissed without crashing Gnumeric.

Expected Results:  Detached toolbars can be moved and re-attached to
the window. Gnumeric quits gracefully.

Additional info:

GNOME version = 2.8.0-5
Comment 1 Caolan McNamara 2005-01-27 09:23:52 EST
There's been rearchitecting of the toolbars in the 2.4 series in rawhide, and
the problem is gone with that version. 
Comment 2 Haran Sivakumaran 2005-01-27 18:42:03 EST
Is there a workaround for the current version in FC3, or are you
planning on releasing an update that solves the problem? I'm stuck
with the toolbars in inconvenient locations and it makes Gnumeric
largely unusable.

Note You need to log in before you can comment on or make changes to this bug.