Bug 1463489 - [RFE] make it possible to install Satellite's httpd with mpm_event
[RFE] make it possible to install Satellite's httpd with mpm_event
Status: POST
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.2.8
Unspecified Unspecified
unspecified Severity medium (vote)
: Beta
: --
Assigned To: Ewoud Kohl van Wijngaarden
Katello QA List
: FutureFeature, Triaged
Depends On: 1425505
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-21 01:49 EDT by Jan Hutař
Modified: 2018-05-18 01:48 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
httpd RSS memory usage comparision for different MPM setting and different number of concurrent registrations (582.35 KB, image/png)
2017-06-21 01:57 EDT, Jan Hutař
no flags Details
same comparison of graph but for system load (965.59 KB, image/png)
2017-06-21 01:59 EDT, Jan Hutař
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 20889 None None None 2017-09-11 08:36 EDT

  None (edit)
Description Jan Hutař 2017-06-21 01:49:21 EDT
Description of problem:
We did some measurement for number of concurrent registrations with Satellite on default mpm_prefork vs. mpm_event and with mpm_event, we saw significant saving in RSS memory consumed by httpd processes.


Version-Release number of selected component (if applicable):
Satellite 6.2.9


How reproducible:
always


Steps to Reproduce:
1. measure RSS usage of all httpd processes together with default (currently
   mpm_prefork) setting during concurrent registration of 140 hosts
2. measure RSS usage of all httpd processes together with mpm_event setting
   configured during concurrent registration of 140 hosts


Actual results:
RSS memory usage in first case was about 2 GB, in second case 760 MB.


Additional info:
As discussed, it is important to carefully sanity-test Satellite in regards of functionality and performance.
Comment 3 Jan Hutař 2017-06-21 01:57 EDT
Created attachment 1289934 [details]
httpd RSS memory usage comparision for different MPM setting and different number of concurrent registrations

Graph shows memory consumption on Satellite in a time
period of all the clients being processed (and returned 0 - except for a
last row where some of them failed because of timeout).

So if registration command on clients was running:
 client1: 12:00:00 - 12:01:00
 client2: 12:00:00 - 12:01:10
 client3: 12:00:20 - 12:01:25
graph shows time range of 12:00:00 - 12:01:25 (well, actually it adds 10
second boundary, so it shows 11:59:50 - 12:01:35).
Comment 4 Jan Hutař 2017-06-21 01:59 EDT
Created attachment 1289935 [details]
same comparison of graph but for system load
Comment 6 Pradeep Kumar Surisetty 2017-06-23 04:31:30 EDT
can we clone this bz to upstream foreman issue
Comment 8 Ewoud Kohl van Wijngaarden 2017-09-11 08:09:18 EDT
The easiest way is adding a line to custom-hiera.yaml:

apache::mpm_module: event

Then rerunning the installer should be sufficient to switch the MPM worker and should work for any installer version that supports custom-hiera.yaml.
Comment 9 Ewoud Kohl van Wijngaarden 2017-09-11 08:36:23 EDT
Created redmine issue http://projects.theforeman.org/issues/20889 from this bug
Comment 10 pm-sat@redhat.com 2017-09-11 14:03:28 EDT
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/20889 has been resolved.
Comment 11 Ewoud Kohl van Wijngaarden 2017-09-19 10:51:05 EDT
It turns out there's a bug in Apache with the MPM event worker that's fixed in 2.4.25: AH00485: scoreboard is full, not at MaxRequestWorkers. Due to this we might roll back the fix in upstream until the fix is backported. Using the httpd24 SCL (which contains the fix) is not an option because its too invasive in the system.
Comment 14 Ewoud Kohl van Wijngaarden 2018-04-24 11:43:42 EDT
Setting back to NEW since it was reverted in upstream. We either need a fix in EL7's httpd (which was closed as WONTFIX) or move to the httpd SCL.
Comment 15 pm-sat@redhat.com 2018-04-24 12:26:01 EDT
Upstream bug assigned to ekohlvan@redhat.com
Comment 16 pm-sat@redhat.com 2018-04-24 12:26:06 EDT
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/20889 has been resolved.

Note You need to log in before you can comment on or make changes to this bug.