Bug 1463694 - BUG: unable to persistently delete the pcmoore / module-testmodule-master-20170509201446 project
BUG: unable to persistently delete the pcmoore / module-testmodule-master-201...
Status: CLOSED CURRENTRELEASE
Product: Copr
Classification: Community
Component: frontend (Show other bugs)
unspecified
All Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Jakub Kadlčík
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-21 10:09 EDT by Paul Moore
Modified: 2017-10-02 11:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-02 11:00:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Moore 2017-06-21 10:09:18 EDT
Description of problem:
Despite deleting the pcmoore / module-testmodule-master-20170509201446 project multiple times, it keeps reappearing when I login to COPR.

Additional info:

https://copr.fedorainfracloud.org/coprs/pcmoore/module-testmodule-master-20170509201446
Comment 1 clime 2017-06-21 10:34:05 EDT
Every ten minutes, there is an attempt to create the project:

Example:

209.132.184.54 - - [18/Jun/2017:11:45:48 +0000] "POST /api/coprs/pcmoore/module-testmodule-master-20170509201446/module/make/

Usually this ends up in 500 fatal error because a project with the same name already exists but if you delete it, then it is recreated again.

Any chance you have setup a cron script to auto-create the project? The script is running somewhere but the question is where.
Comment 2 clime 2017-06-21 10:37:47 EDT
Actually, you are not the only one who has got this problem. That probably means there is something quite off with project creation logic for "modules".
Comment 3 Paul Moore 2017-08-03 09:24:35 EDT
My apologies, for some reason I never received notification emails for your above comments.

To answer your question from comment #1, no there is no cron job or any similar process which is set to (re)create the project; although it looks like you may have found a possible root cause in comment #2.  Any updates?
Comment 4 clime 2017-08-03 09:36:15 EDT
(In reply to Paul Moore from comment #3)
> My apologies, for some reason I never received notification emails for your
> above comments.
> 
> To answer your question from comment #1, no there is no cron job or any
> similar process which is set to (re)create the project; although it looks
> like you may have found a possible root cause in comment #2.  Any updates?

This is a bug in COPR<->MBS integration. That's all I can tell. I will try to reassign it to somebody who might know more.
Comment 5 Paul Moore 2017-08-08 14:40:14 EDT
Hi Jakub, any ideas as to what the problem might be?
Comment 6 Paul Moore 2017-08-25 10:44:08 EDT
I tried deleting the COPR repository again, the problem still persists.  Help?
Comment 7 Jakub Kadlčík 2017-09-10 22:08:03 EDT
So I've marked the module as failed. It shouldn't create the project anymore. Paul, can you please try to delete it once more?

@clime, just for the record, I did this on MBS database

>> select id, state from module_builds where name='testmodule' and stream='master' and version=20170509201446;

The id was 19 and state was 2, which means that build is in progress. It shouldn't have since one of it's components failed.

>> update module_builds set state=4, state_reason='Manually killed' where id=19;
Comment 8 Paul Moore 2017-09-12 12:08:18 EDT
I just deleted the project, let's see if it sticks this time ...
Comment 9 Paul Moore 2017-10-02 11:00:29 EDT
It's been a couple of weeks and the project hasn't been recreated so I think we can consider this fixed.  Thanks for your help!

Note You need to log in before you can comment on or make changes to this bug.