Bug 146390 - connlimit extension is not working
connlimit extension is not working
Status: CLOSED DUPLICATE of bug 118888
Product: Fedora
Classification: Fedora
Component: iptables (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-27 15:05 EST by Jens Hardings Perl
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:08:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Hardings Perl 2005-01-27 15:05:11 EST
Description of problem:

trying to insert a rule that uses the connlimit extension results in
an error message: "iptables: No chain/target/match by that name",
without inserting the rule.

Version-Release number of selected component (if applicable):
iptables-1.2.11-3.1.FC3
kernel-2.6.10-1.741_FC3

How reproducible: always

Steps to Reproduce:

Type this command as root:
# iptables -t filter -I INPUT -p tcp --syn --destination
192.168.10.116 --dport 80 -m connlimit --connlimit-above 2 -j LOG
  
Actual results:

Returns error message: "iptables: No chain/target/match by that name",
'iptables -L INPUT' indicates that the rule has not been added.

Expected results:
'iptables -L INPUT' should show the new rule.

Additional info:

This command works seamlessly:
# iptables -t filter -I INPUT -p tcp --syn --destination
192.168.10.116 --dport 80 -j LOG

This command requires the use of "connlimit-above" argument (which
indicates that the connlimit extension is being used):
# iptables -t filter -I INPUT -p tcp --syn --destination
192.168.10.116 --dport 80 -m connlimit -j LOG
Comment 1 Jens Hardings Perl 2005-02-04 11:24:28 EST

*** This bug has been marked as a duplicate of 118888 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:08:04 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.