Bug 1463918 - [abrt] clinfo: llvm::cast<llvm::CompositeType, llvm::Type>(): clinfo killed by signal 6
[abrt] clinfo: llvm::cast<llvm::CompositeType, llvm::Type>(): clinfo killed b...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: beignet (Show other bugs)
26
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Igor Gnatenko
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:08a423c2005e8b1f00ff1aca840...
:
: 1470379 1471673 (view as bug list)
Depends On: 1458595
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-22 02:33 EDT by Jia Yuan Lo
Modified: 2017-07-17 08:35 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-14 06:31:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (36.46 KB, text/plain)
2017-06-22 02:33 EDT, Jia Yuan Lo
no flags Details
File: cgroup (289 bytes, text/plain)
2017-06-22 02:33 EDT, Jia Yuan Lo
no flags Details
File: core_backtrace (10.00 KB, text/plain)
2017-06-22 02:33 EDT, Jia Yuan Lo
no flags Details
File: cpuinfo (1.25 KB, text/plain)
2017-06-22 02:33 EDT, Jia Yuan Lo
no flags Details
File: dso_list (5.44 KB, text/plain)
2017-06-22 02:33 EDT, Jia Yuan Lo
no flags Details
File: environ (3.04 KB, text/plain)
2017-06-22 02:33 EDT, Jia Yuan Lo
no flags Details
File: limits (1.29 KB, text/plain)
2017-06-22 02:33 EDT, Jia Yuan Lo
no flags Details
File: maps (25.76 KB, text/plain)
2017-06-22 02:33 EDT, Jia Yuan Lo
no flags Details
File: open_fds (491 bytes, text/plain)
2017-06-22 02:33 EDT, Jia Yuan Lo
no flags Details
File: proc_pid_status (1.26 KB, text/plain)
2017-06-22 02:33 EDT, Jia Yuan Lo
no flags Details
File: var_log_messages (302 bytes, text/plain)
2017-06-22 02:34 EDT, Jia Yuan Lo
no flags Details

  None (edit)
Description Jia Yuan Lo 2017-06-22 02:33:28 EDT
Version-Release number of selected component:
clinfo-2.1.17.02.09-1.fc26

Additional info:
reporter:       libreport-2.9.1
backtrace_rating: 4
cmdline:        clinfo
crash_function: llvm::cast<llvm::CompositeType, llvm::Type>
executable:     /usr/bin/clinfo
journald_cursor: s=aa40b9a704cd4bb1a4b065f3c04b39e3;i=350e;b=ce7e9b6f267046cd9997392945aa8830;m=92d7134;t=55286833de321;x=e46121acc40b8b35
kernel:         4.11.5-300.fc26.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 1 Jia Yuan Lo 2017-06-22 02:33:37 EDT
Created attachment 1290505 [details]
File: backtrace
Comment 2 Jia Yuan Lo 2017-06-22 02:33:39 EDT
Created attachment 1290506 [details]
File: cgroup
Comment 3 Jia Yuan Lo 2017-06-22 02:33:42 EDT
Created attachment 1290507 [details]
File: core_backtrace
Comment 4 Jia Yuan Lo 2017-06-22 02:33:44 EDT
Created attachment 1290508 [details]
File: cpuinfo
Comment 5 Jia Yuan Lo 2017-06-22 02:33:47 EDT
Created attachment 1290509 [details]
File: dso_list
Comment 6 Jia Yuan Lo 2017-06-22 02:33:49 EDT
Created attachment 1290510 [details]
File: environ
Comment 7 Jia Yuan Lo 2017-06-22 02:33:51 EDT
Created attachment 1290511 [details]
File: limits
Comment 8 Jia Yuan Lo 2017-06-22 02:33:54 EDT
Created attachment 1290512 [details]
File: maps
Comment 9 Jia Yuan Lo 2017-06-22 02:33:56 EDT
Created attachment 1290513 [details]
File: open_fds
Comment 10 Jia Yuan Lo 2017-06-22 02:33:59 EDT
Created attachment 1290514 [details]
File: proc_pid_status
Comment 11 Jia Yuan Lo 2017-06-22 02:34:01 EDT
Created attachment 1290515 [details]
File: var_log_messages
Comment 12 Pavel Ondračka 2017-07-07 12:27:11 EDT
Similar problem has been detected:

1) run clinfo

reporter:       libreport-2.9.1
backtrace_rating: 4
cmdline:        clinfo
crash_function: llvm::cast<llvm::CompositeType, llvm::Type>
executable:     /usr/bin/clinfo
journald_cursor: s=7aceeb3fb0014ea78a17bb71d77985b3;i=dc5;b=f1a57accdf0441989a0328b503b293ac;m=4bb5c7dcb;t=553bc997dac3e;x=83172dfc0fc94670
kernel:         4.11.9-300.fc26.x86_64
package:        clinfo-2.1.17.02.09-1.fc26
reason:         clinfo killed by signal 6
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 13 Jia Yuan Lo 2017-07-07 13:08:45 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=1458595

Somebody suggests "sudo rpm -e beignet"
but this will remove Intel GPU OpenCL capability
leaving only with Intel CPU doing OpenCL
Comment 14 Jan Vesely 2017-07-12 17:05:37 EDT
Similar problem has been detected:

running OCL_ICD_VENDORS=/etc/OpenCL/vendors/intel-beignet.icd clinfo

it thits assertion failure:
$ OCL_ICD_VENDORS=/etc/OpenCL/vendors/intel-beignet.icd clinfo 
Number of platforms                               1
  Platform Name                                   Intel Gen OCL Driver
  Platform Vendor                                 Intel
  Platform Version                                OpenCL 2.0 beignet 1.3
  Platform Profile                                FULL_PROFILE
  Platform Extensions                             cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_byte_addressable_store cl_khr_3d_image_writes cl_khr_image2d_from_buffer cl_khr_depth_images cl_khr_icd cl_intel_accelerator cl_intel_subgroups cl_intel_subgroups_short cl_khr_gl_sharing
  Platform Extensions function suffix             Intel
clinfo: /usr/include/llvm/Support/Casting.h:236: typename llvm::cast_retty<X, Y*>::ret_type llvm::cast(Y*) [with X = llvm::CompositeType; Y = llvm::Type; typename llvm::cast_retty<X, Y*>::ret_type = llvm::CompositeType*]: Assertion `isa<X>(Val) && "cast<Ty>() argument of incompatible type!"' failed.
Aborted (core dumped)

reporter:       libreport-2.9.1
backtrace_rating: 4
cmdline:        clinfo
crash_function: llvm::cast<llvm::CompositeType, llvm::Type>
executable:     /usr/bin/clinfo
journald_cursor: s=84259e79c84044d3afa1be6846784cf9;i=533903;b=a237e17d06a847d59ca065c87c4bab6f;m=8d45e7f3;t=554251d7be75f;x=ad46c500c5d6286c
kernel:         4.11.9-200.fc25.x86_64
package:        clinfo-2.1.17.02.09-1.fc26
reason:         clinfo killed by signal 6
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 15 Debarshi Ray 2017-07-17 08:32:15 EDT
*** Bug 1470379 has been marked as a duplicate of this bug. ***
Comment 16 Debarshi Ray 2017-07-17 08:35:28 EDT
Looks like this was fixed in beignet-1.3.1-3.git20170622.36f6a8b
Comment 17 Debarshi Ray 2017-07-17 08:35:51 EDT
*** Bug 1471673 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.