Bug 1464189 - Lenovo T470p volume buttons do not work
Lenovo T470p volume buttons do not work
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pulseaudio (Show other bugs)
7.4
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Wim Taymans
Desktop QE
: Regression
Depends On:
Blocks: 1438583 1450449 1450506
  Show dependency treegraph
 
Reported: 2017-06-22 11:31 EDT by pgozart
Modified: 2017-08-18 14:40 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-11 08:54:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3146461 None None None 2017-08-09 19:21 EDT

  None (edit)
Description pgozart 2017-06-22 11:31:34 EDT
Description of problem:
Brightness buttons work i.e. f5 and f6
Volume buttons do not work i.e. f2 f3


Version-Release number of selected component (if applicable):
RHEL 7.4 HTB


How reproducible:
Always


Steps to Reproduce:
1. Tap F2/F3 buttons on Lenovo T470p running RHEL 7.4 


Actual results:
Volume is not changed.


Expected results:
Volume is changed.


Additional info:
SFDC case 01875812 has a sosreport attached.
Comment 3 Joseph Kachuck 2017-06-22 13:15:29 EDT
Hello Pgozart,
Please confirm if you are able to recreate this on RHEL 7.3?

Thank You
Joe Kachuck
Comment 5 Joseph Kachuck 2017-06-22 13:20:50 EDT
Hello Lenovo,
Would you be able to confirm if this is tested by Lenovo?

Thank You
Joe Kachuck
Comment 6 Ocean He 2017-06-22 22:41:54 EDT
Hi Pgozart,

I am not fully understanding what's going on here:

Does T470p means ThinkPad T470p? If yes, then Floyd call Peter help on this.

What the RHEL7.4 HTB means?

Ocean.
Comment 7 Joseph Kachuck 2017-06-23 10:29:43 EDT
Hello Lenovo,
HTB means = "High Touch Beta"

I believe T470P means Thinkpad T470P.
Pgozart please confirm this.

Thank You
Joe Kachuck
Comment 9 Wim Taymans 2017-06-26 02:58:51 EDT
First thing to check is if the keys get correctly mapped. Do you see any feedback on the screen that the volume button is pressed, like the gnome volume popup?
Comment 10 Bastien Nocera 2017-06-26 06:36:16 EDT
(In reply to Wim Taymans from comment #9)
> First thing to check is if the keys get correctly mapped. Do you see any
> feedback on the screen that the volume button is pressed, like the gnome
> volume popup?

Run evtest as root first, and see whether any of the devices in the list respond to the key presses for those keys.

If none do, then it's a driver problem in the kernel.
Comment 12 Christian Kellner 2017-06-27 09:09:17 EDT
Tried to reproduce on a X270 (also a 2017 Lenovo model), but the volume buttons work fine on that machine (btw, FN lock was on by default on this machine, so it was Fn+F2/Fn+F3).
Comment 14 pgozart 2017-06-28 10:49:22 EDT
I got the following answers back from the customer.  --Paul

==============================

There is no evtest for RHEL7.
Grabbed it from here.
https://copr-be.cloud.fedoraproject.org/results/lzachar/sundry/epel-7-x86_64/00139213-evtest/evtest-1.33-1.el7.centos.x86_64.rpm
Note the differences.

7.4
evtest 
No device specified, trying to scan all of /dev/input/event*
Available devices:
/dev/input/event0:	Sleep Button
/dev/input/event1:	Lid Switch
/dev/input/event2:	Power Button
/dev/input/event3:	AT Translated Set 2 keyboard
/dev/input/event4:	SynPS/2 Synaptics TouchPad
/dev/input/event5:	Video Bus
/dev/input/event6:	Video Bus
/dev/input/event7:	TPPS/2 IBM TrackPoint
/dev/input/event8:	PC Speaker
/dev/input/event9:	Raydium Corporation Raydium Touch System
/dev/input/event10:	ThinkPad Extra Buttons
/dev/input/event11:	Integrated Camera
/dev/input/event12:	HDA Intel PCH Mic
/dev/input/event13:	HDA Intel PCH Headphone
/dev/input/event14:	HDA Intel PCH HDMI/DP,pcm=3
/dev/input/event15:	HDA Intel PCH HDMI/DP,pcm=7
/dev/input/event16:	HDA Intel PCH HDMI/DP,pcm=8

7.3
evtest 
No device specified, trying to scan all of /dev/input/event*
Available devices:
/dev/input/event0:	Sleep Button
/dev/input/event1:	Lid Switch
/dev/input/event2:	Power Button
/dev/input/event3:	AT Translated Set 2 keyboard
/dev/input/event4:	SynPS/2 Synaptics TouchPad
/dev/input/event5:	Video Bus
/dev/input/event6:	Video Bus
/dev/input/event7:	TPPS/2 IBM TrackPoint
/dev/input/event8:	PC Speaker
/dev/input/event9:	Raydium Corporation Raydium Touch System
/dev/input/event10:	Integrated Camera
/dev/input/event11:	HDA Intel PCH Mic
/dev/input/event12:	HDA Intel PCH Headphone
/dev/input/event13:	HDA Intel PCH HDMI/DP,pcm=3
/dev/input/event14:	HDA Intel PCH HDMI/DP,pcm=7
/dev/input/event15:	HDA Intel PCH HDMI/DP,pcm=8

(In reply to Gozart, Paul)
> Hi Grant,
> 
> Engineering has a few questions about this issue.
> 
> 1) Does this issue exists on this model in 7.3 (is this regression)?
> 2) Do you see any feedback on the screen that the volume button is pressed, like the gnome volume popup (are the buttons mapped)?
> 3) If you run `evtest` as root, do any of the devices in the list respond to the key presses for those keys (is this a kernel issue)?
> 
> Please reply at your earliest convenience so Engineering can continue working on this.  
> 
> Thanks,
> Paul

----------------------

Pressing Fn+F2 and Fn+F3 does not work
Pressing Alt+F2 and Alt+f3 does work.

(In reply to Gozart, Paul)
> Hi Grant,
> 
> Sorry for all the questions, but Engineering has another easy question.  They tried to reproduce on a X270 (also a 2017 Lenovo model) and the volume was able to be changed using the function key (eg Fn+F2 and Fn+F3).  Can you try this and report back as well?  
> 
> Note also that they thought the function key was locked on by default on the X270 which caused some confusion.
> 
> Thanks,
> Paul

-----------------------

Tested on 7.3 you can click f2/f3 to change volume, no need to press any additional key.

(In reply to Gozart, Paul)
> Hello Grant,
> 
> Do you happen to know if this issue exists on this model in 7.3?
> 
> Thanks,
> Paul

--------------------------

Specs from lenovo
Intel® HD Graphics 630
NVIDIA® GeForce® 940MX 2GB GDDR5
with 14" FHD(1920 x 1080) IPS Touch

How do I detect if it is a HIDP?
Comment 16 Bastien Nocera 2017-06-29 07:30:18 EDT
(In reply to pgozart from comment #14)
> I got the following answers back from the customer.  --Paul
> 
> ==============================
> 
> There is no evtest for RHEL7.
> Grabbed it from here.
> https://copr-be.cloud.fedoraproject.org/results/lzachar/sundry/epel-7-x86_64/
> 00139213-evtest/evtest-1.33-1.el7.centos.x86_64.rpm
> Note the differences.
> 
> 7.4
> evtest 
> No device specified, trying to scan all of /dev/input/event*
> Available devices:
> /dev/input/event0:	Sleep Button
> /dev/input/event1:	Lid Switch
> /dev/input/event2:	Power Button
> /dev/input/event3:	AT Translated Set 2 keyboard
> /dev/input/event4:	SynPS/2 Synaptics TouchPad
> /dev/input/event5:	Video Bus
> /dev/input/event6:	Video Bus
> /dev/input/event7:	TPPS/2 IBM TrackPoint
> /dev/input/event8:	PC Speaker
> /dev/input/event9:	Raydium Corporation Raydium Touch System
> /dev/input/event10:	ThinkPad Extra Buttons
> /dev/input/event11:	Integrated Camera
> /dev/input/event12:	HDA Intel PCH Mic
> /dev/input/event13:	HDA Intel PCH Headphone
> /dev/input/event14:	HDA Intel PCH HDMI/DP,pcm=3
> /dev/input/event15:	HDA Intel PCH HDMI/DP,pcm=7
> /dev/input/event16:	HDA Intel PCH HDMI/DP,pcm=8
> 
> 7.3
> evtest 
> No device specified, trying to scan all of /dev/input/event*
> Available devices:
> /dev/input/event0:	Sleep Button
> /dev/input/event1:	Lid Switch
> /dev/input/event2:	Power Button
> /dev/input/event3:	AT Translated Set 2 keyboard
> /dev/input/event4:	SynPS/2 Synaptics TouchPad
> /dev/input/event5:	Video Bus
> /dev/input/event6:	Video Bus
> /dev/input/event7:	TPPS/2 IBM TrackPoint
> /dev/input/event8:	PC Speaker
> /dev/input/event9:	Raydium Corporation Raydium Touch System
> /dev/input/event10:	Integrated Camera
> /dev/input/event11:	HDA Intel PCH Mic
> /dev/input/event12:	HDA Intel PCH Headphone
> /dev/input/event13:	HDA Intel PCH HDMI/DP,pcm=3
> /dev/input/event14:	HDA Intel PCH HDMI/DP,pcm=7
> /dev/input/event15:	HDA Intel PCH HDMI/DP,pcm=8

You're supposed to then choose one of the devices and press the keyboard keys to see if they generate events. I'm guessing "ThinkPad Extra Buttons" on 7.4 is a good place to start.
Comment 17 Christian Kellner 2017-07-11 07:56:01 EDT
I just installed 7.4 Beta on a T470p and I can *not* reproduce the problem: with the exception of the new extra button, the thinkpad buttons, including the volume related ones, work fine.
The kernel: 3.10.0-663.el7.x86_64 with GNOME 3.22.2.
Comment 18 Tomas Pelka 2017-07-11 08:54:56 EDT
I can't reproduce either, let me close as current release.

Note You need to log in before you can comment on or make changes to this bug.