Bug 1464458 - Wrong regexp in rpm.attr file in scl-utils-build
Wrong regexp in rpm.attr file in scl-utils-build
Status: CLOSED NOTABUG
Product: Red Hat Software Collections
Classification: Red Hat
Component: rh-postgresql96 (Show other bugs)
rh-postgresql96
Unspecified Unspecified
unspecified Severity unspecified
: beta
: ---
Assigned To: Databases Maintanance List
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-23 09:32 EDT by Pavel Raiskup
Modified: 2017-06-26 04:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-26 04:14:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Raiskup 2017-06-23 09:32:14 EDT
Created attachment 1291050 [details]
Proposed fix.

After I started using %filter_provides_in in rh-postgresql96 (because the
bug 1464368 is also in RHEL7), the scl tooling started to choke ... Turns
out that similar issue which is in upstream [1] is also present in RHEL 7.

See the log [2] for the error logs:
...
warning: Ignoring invalid regex ^%{_scl_prefix}/.*$|%{_root_sysconfdir}/rpm/macros.rh-postgresql96-config$
warning: Ignoring invalid regex ^%{_scl_prefix}/.*$|%{_root_sysconfdir}/rpm/macros.rh-postgresql96-config$
warning: Ignoring invalid regex ^%{_scl_prefix}/.*$|%{_root_sysconfdir}/rpm/macros.rh-postgresql96-config$
warning: Ignoring invalid regex ^%{_scl_prefix}/.*$|%{_root_sysconfdir}/rpm/macros.rh-postgresql96-config$
warning: Ignoring invalid regex ^%{_scl_prefix}/.*$|%{_root_sysconfdir}/rpm/macros.rh-postgresql96-config$
warning: Ignoring invalid regex ^%{_scl_prefix}/.*$|%{_root_sysconfdir}/rpm/macros.rh-postgresql96-config$
warning: Ignoring invalid regex ^%{_scl_prefix}/.*$|%{_root_sysconfdir}/rpm/macros.rh-postgresql96-config$
warning: Ignoring invalid regex ^%{_scl_prefix}/.*$|%{_root_sysconfdir}/rpm/macros.rh-postgresql96-config$
...

[1] https://github.com/sclorg/scl-utils/pull/13
[2] https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=567922
Comment 2 Pavel Raiskup 2017-06-23 09:40:55 EDT
Nope, the attached patch doesn't help.  There must be something different.
Comment 3 Pavel Raiskup 2017-06-23 11:02:15 EDT
Switching against rh-postgresql96 for now.
Comment 5 Panu Matilainen 2017-06-26 03:47:07 EDT
The older filter_* family of macros is not compatible with the *exclude* built-in filtering directives, you can't mix and match them.

%filter_setup switches to the "external dependency generator" mode which has all sorts of side-effects, one of which is that rpm's dependency generator is executed as a separate executable, so none of spec or cli-defined macros will be present.
Comment 6 Pavel Raiskup 2017-06-26 04:14:11 EDT
Yeah, I noticed that, fixed by:
http://pkgs.devel.redhat.com/cgit/rpms/postgresql/commit/?h=rhscl-3.0-rh-postgresql96-rhel-7&id=a35af9b9f1dbdbde19a4f8a59

Thanks for having a look!

Note You need to log in before you can comment on or make changes to this bug.