Bug 146449 - Rebuilding of php rpm dies
Rebuilding of php rpm dies
Status: CLOSED DUPLICATE of bug 138441
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-28 07:05 EST by mlbossi
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-28 08:17:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/usr/src/redhat/BUILD/php-4.3.10/build-cgi/config.log (209.41 KB, text/plain)
2005-01-28 08:13 EST, mlbossi
no flags Details

  None (edit)
Description mlbossi 2005-01-28 07:05:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
Rebuilding of the php package dies (with the default php.spec):

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define COOKIE_IO_FUNCTIONS_T cookie_io_functions_t
#define COOKIE_SEEKER_USES_OFF64_T 1
#define DEFAULT_SHORT_OPEN_TAG "1"

... (skip) ...

#define PHP_WRITE_STDOUT 1
#define SIZEOF_INT 4
#define SIZEOF_LONG 4
#define STDC_HEADERS 1
#define WITH_BCMATH 1
#endif
#ifdef __cplusplus
extern "C" void std::exit (int) throw (); using std::exit;

configure: exit 1
+ make
make: *** No targets specified and no makefile found.  Stop.
error: Bad exit status from /var/tmp/rpm-tmp.88292 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.88292 (%build)



Version-Release number of selected component (if applicable):
php-4.3.10-3.2

How reproducible:
Always

Steps to Reproduce:
1. Install php srpm with dependecies resolved
2. Run: rpmbuild -bb /usr/src/redhat/SPEC/php.spec
3. Die with an strange error
  

Additional info:

This bug is similar to "Bug 131054 � Rebuilding of php dies if file package is too old" but the linux box is up2date
Comment 1 Joe Orton 2005-01-28 08:06:59 EST
Please attach the config.log file left after the failed build, in
/path/to/BUILD/php-4.3.10/build-cgi/.
Comment 2 mlbossi 2005-01-28 08:13:42 EST
Created attachment 110351 [details]
/usr/src/redhat/BUILD/php-4.3.10/build-cgi/config.log

As required...
Thank you
Comment 3 Joe Orton 2005-01-28 08:17:53 EST
You need to install libidn-devel.

*** This bug has been marked as a duplicate of 138441 ***
Comment 4 mlbossi 2005-01-28 09:53:41 EST
Ok, now is working!
Thanks a lot!

Note You need to log in before you can comment on or make changes to this bug.