Bug 146454 - Empty mails are being sent
Empty mails are being sent
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.17
All Linux
medium Severity low (vote)
: ---
: ---
Assigned To: David Lawrence
Mike MacKenzie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-28 08:34 EST by Zenon Panoussis
Modified: 2007-04-18 13:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-16 00:59:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zenon Panoussis 2005-01-28 08:34:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:

Bugzilla sends mails like this (irrelevant Received: headers snipped):

========================begin============================
Date: Fri, 28 Jan 2005 07:17:40 -0500
Message-Id: <200501281217.j0SCHeB5031710@www.beta.redhat.com>
From: bugzilla@redhat.com
To: redhatbugzilla@provocation.net
Subject: [Bug 127726] dhclient remains active after change of bootproto
Content-type: text/plain; charset=utf-8
In-Reply-To: <bugzilla-127726@redhat.com>
X-Loop: bugzilla@redhat.com
X-BeenThere: bugzilla@redhat.com
X-Bugzilla-Product: Red Hat Enterprise Linux
X-Bugzilla-Version: 3
X-Bugzilla-Component: initscripts
X-Bugzilla-Comment: Public
X-Bugzilla-Reason: Reporter
X-Bugzilla-Changed-Fields: Comment

Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug report.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=127726







------- You are receiving this mail because: -------
You reported the bug, or are watching the reporter.
=========================end=============================

Although the headers claim that a comment was added/changed, no
comment was added nor changed in the bug. I think I have received more
such empty mails on this particular bug.

Bug #127726 blocks three private bugs which I can't view. My guess is
that something added in the blocked bugs triggered bugzilla to send
mail down the food chain too. If that it so, bugzilla should either
add an explanatory but non-disclosing comment in the mail, like
"comment/person/attachment added to blocked bug #999999", or not send
mail up the dependecies at all. 

Note that I reported #127726 in bugzilla-current but the message-ID of
the mail says beta, so the version-release of this bug might be wrong. 



Version-Release number of selected component (if applicable):
2.17.1

How reproducible:
Didn't try
Comment 1 David Lawrence 2005-03-16 00:59:52 EST
Should be fixed in new release of Bugzilla.
Comment 2 Zenon Panoussis 2005-03-16 01:43:43 EST
While you're at it, one more thing. Closing this bug caused the following 
mail to be sent:

===============================================================
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=146454


dkl@redhat.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |CLOSED
         Resolution|                            |CURRENTRELEASE

<snip rest>
===============================================================

The URL in the message is wrong and gives a 500 error. 
https://bugzilla.redhat.com/beta/ works and 
https://bugzilla.redhat.com/bugzilla-old/ works too, but 
https://bugzilla.redhat.com/bugzilla/ no longer exists. The 
mails sent by both bugzillas need to be adjusted accordingly. 

Note You need to log in before you can comment on or make changes to this bug.