Bug 1464561 - Horizon dashboard stop responding with gateway timeout error [NEEDINFO]
Horizon dashboard stop responding with gateway timeout error
Status: CLOSED WORKSFORME
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
10.0 (Newton)
Unspecified Unspecified
medium Severity medium
: Upstream M2
: 13.0 (Queens)
Assigned To: Radomir Dopieralski
Ido Ovadia
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-23 14:32 EDT by bigswitch
Modified: 2017-12-01 09:38 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-01 09:38:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rdopiera: needinfo? (rhosp-bugs-internal)


Attachments (Terms of Use)

  None (edit)
Description bigswitch 2017-06-23 14:32:16 EDT
Description of problem:
Seen in rhosp 10 horizon dashboard. After running few days, I am able to login  as admin to horizon and view the identity tab. However clicking on the admin tab will timeout with error 504 gateway timeout error.

Version-Release number of selected component (if applicable):
RHOSP 10

How reproducible:
100%

Will upload sosreport from all three controllers to box and provide link
Comment 1 bigswitch 2017-06-23 14:37:06 EDT
sosreport at box

https://bigswitch.box.com/s/v35bzttawrg05iw07qoz6kedmzih0jds
Comment 2 Radomir Dopieralski 2017-06-26 03:24:59 EDT
I don't see any errors related to that in the horizon or apache logs on your controllers. That suggests that the error may be actually happening earlier, when the haproxy is trying to reach your controller nodes.
Comment 3 Radomir Dopieralski 2017-06-29 11:32:14 EDT
Can you verify that there are no network connectivity problems with the controller?

Also, when that happens, does only happen with that single view, or all of Horizon?
Comment 4 Radomir Dopieralski 2017-06-29 11:33:15 EDT
Can you also show us the logs of HAProxy?
Comment 5 bigswitch 2017-06-29 12:45:25 EDT
Hi 
There is no network connectivity issue. I am able to login to Horizon Identity dashboard everytime. From there, if I attempt to navigate to the admin or project tab thats when it start to timeout. If I attempt to login to Identity again it will succeed, but attempt to navigate to admin tab or project tab will timeout again.
btw, I dont see haproxy log in /var/log/. where can I grab it?

Thanks
Comment 6 Radomir Dopieralski 2017-08-04 05:01:47 EDT
Hi, does this happen on rhos 7.4 by any chance? Because we have a similar problem with mod_wsgi there: https://bugzilla.redhat.com/show_bug.cgi?id=1478042
Comment 8 Radomir Dopieralski 2017-12-01 09:38:19 EST
Since there is no response, I assume the problem was somehow fixed in the mean time. If the problem is still there, please reopen this issue.

Note You need to log in before you can comment on or make changes to this bug.