Bug 1464607 - Radio button has value selected when it should not in SUI
Radio button has value selected when it should not in SUI
Status: CLOSED DUPLICATE of bug 1466340
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - Service (Show other bugs)
5.8.0
Unspecified Unspecified
medium Severity medium
: GA
: cfme-future
Assigned To: Chris Hale
Dave Johnson
:
Depends On: 1466340
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-23 18:14 EDT by Brant Evans
Modified: 2017-07-06 12:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-06 12:53:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brant Evans 2017-06-23 18:14:51 EDT
Description of problem:
When ordering a Catalog Item in the SUI a radio button Service Dialog element has a value selected when there is no default. The value selected is the first value in the radio button list.

Version-Release number of selected component (if applicable):
5.8.0

How reproducible:
Always

Steps to Reproduce:
1. Create a Service Dialog that has a Radio button element. The element should not have a default value selected.
2. Create a Service Catalog Item that uses the above created Service Dialog
3. Order the Service Catalog Item via the SUI

Actual results:
All radio button elements have a value selected by default.


Expected results:
There should be no value selected by default.


Additional info:
This works as expected in the OPS UI.
Comment 2 Chris Kacerguis 2017-06-23 19:11:03 EDT
Currently, dialogs are getting re-written.  Here is the EPIC: 

https://www.pivotaltracker.com/epic/show/3483663
Comment 3 Chris Kacerguis 2017-06-23 19:11:19 EDT
A Pivotal Tracker story has been created for this Bug: https://www.pivotaltracker.com/story/show/147785905
Comment 4 Chris Kacerguis 2017-07-06 12:53:56 EDT

*** This bug has been marked as a duplicate of bug 1466340 ***
Comment 5 Chris Kacerguis 2017-07-06 12:54:04 EDT
Chris Kacerguis deleted the linked story in Pivotal Tracker

Note You need to log in before you can comment on or make changes to this bug.