Bug 1464637 - After R upgrade RStudio refuses to run
After R upgrade RStudio refuses to run
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: R (Show other bugs)
25
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-23 23:51 EDT by Steve Grubb
Modified: 2017-06-29 12:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-29 10:53:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Grubb 2017-06-23 23:51:02 EDT
Description of problem:
RStudio refuses to run after R update.

Loading required package: shiny

Listening on http://127.0.0.1:4196
Warning: Error in library: there is no package called ‘shinyjs’
Stack trace (innermost first):
    41: library
     1: shiny::runApp
Error : there is no package called ‘shinyjs’
In addition: Warning message:
R graphics engine version 12 is not supported by this version of RStudio. The Plots tab will be disabled until a newer version of RStudio is installed. 
Warning: Error in library: there is no package called ‘shinyjs’
Stack trace (innermost first):
    41: library
     1: shiny::runApp
Error : there is no package called ‘shinyjs’
Warning: Error in library: there is no package called ‘shinyjs’
Stack trace (innermost first):
    41: library
     1: shiny::runApp
Error : there is no package called ‘shinyjs’
Warning: Error in library: there is no package called ‘shinyjs’
Stack trace (innermost first):

Version-Release number of selected component (if applicable):
R-3.4.0-2.fc25


Additional info:
This is a catastrophic failure. R cannot be upgraded to a new major version on a shipped Fedora. Please roll back R on F25.
Comment 1 Tom "spot" Callaway 2017-06-29 10:53:08 EDT
So, let me understand this right, a third party component is not compatible with current R, so we shouldn't move to it? :/

To this specific issue, RStudio is somewhat notorious for breaking when R updates. You often have to update to their preview release to get it working again. When I look at their current Preview page, it mentions this specific error:

https://www.rstudio.com/products/rstudio/download/preview/

"Support for graphical output in R 3.4.0"

This release came out on 2017-04-13, and I suspect, if you had opened an issue with the RStudio folks, they would have pointed you to it.
Comment 2 Steve Grubb 2017-06-29 11:57:53 EDT
I think you're missing the point. The request here is to manage R like we do all other languages. We do not move to a new major gcc during a shipped Fedora, we do not move to a new major Python during a shipped Fedora, we do not move to a new major version of Perl during a shipped Fedora, ...

When switching from Fedora 24 to 25 or 25 to 26, I expect major breakage and delay the upgrade to a point when I can take the time to rebuild everything I need to.

Going forward, can we manage R similar to other languages?
Comment 3 Tom "spot" Callaway 2017-06-29 12:01:59 EDT
R has been maintained this way since its addition to Fedora. The userbase for R is heavily weighted towards academics, and there is a clear interest in having the latest R as soon as possible. Often, I receive emails and bug reports if I do not update R quickly enough. Unlike gcc or perl, R only affects its own ecosystem. There are exactly two packages that are not R modules which depend on R, and both of them are front-ends to R (and are rebuilt/updated whenever R changes).

Note You need to log in before you can comment on or make changes to this bug.