Bug 1464681 - [abrt] lightdm-autologin-greeter: module(): lightdm-autologin-greeter:34:<module>:GLib.GError: lightdm_greeter_error: Can't authenticate autologin; autologin not configured (3)
[abrt] lightdm-autologin-greeter: module(): lightdm-autologin-greeter:34:<mod...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lightdm-autologin-greeter (Show other bugs)
26
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Neal Gompa
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:4fe9e270d67d404d599b4c3f7e8...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-24 09:27 EDT by pizza306
Modified: 2017-07-09 21:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-09 21:35:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.65 KB, text/plain)
2017-06-24 09:27 EDT, pizza306
no flags Details
File: cgroup (289 bytes, text/plain)
2017-06-24 09:27 EDT, pizza306
no flags Details
File: cpuinfo (1.27 KB, text/plain)
2017-06-24 09:27 EDT, pizza306
no flags Details
File: environ (455 bytes, text/plain)
2017-06-24 09:27 EDT, pizza306
no flags Details
File: mountinfo (3.13 KB, text/plain)
2017-06-24 09:27 EDT, pizza306
no flags Details
File: namespaces (102 bytes, text/plain)
2017-06-24 09:27 EDT, pizza306
no flags Details
File: open_fds (597 bytes, text/plain)
2017-06-24 09:27 EDT, pizza306
no flags Details

  None (edit)
Description pizza306 2017-06-24 09:27:38 EDT
Version-Release number of selected component:
lightdm-autologin-greeter-1.0-2.fc26

Additional info:
reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/lightdm-autologin-greeter
crash_function: module
exception_type: GLib.GError
executable:     /usr/bin/lightdm-autologin-greeter
kernel:         4.11.6-301.fc26.x86_64
runlevel:       N 5
type:           Python3
uid:            991

Truncated backtrace:
lightdm-autologin-greeter:34:<module>:GLib.GError: lightdm_greeter_error: Can't authenticate autologin; autologin not configured (3)

Traceback (most recent call last):
  File "/usr/bin/lightdm-autologin-greeter", line 34, in <module>
    greeter.authenticate_autologin()
GLib.GError: lightdm_greeter_error: Can't authenticate autologin; autologin not configured (3)

Local variables in innermost frame:
__name__: '__main__'
__doc__: None
__package__: None
__loader__: <_frozen_importlib_external.SourceFileLoader object at 0x7f67c895f6d8>
__spec__: None
__annotations__: {}
__builtins__: <module 'builtins' (built-in)>
__file__: '/usr/bin/lightdm-autologin-greeter'
__cached__: None
print_function: _Feature((2, 6, 0, 'alpha', 2), (3, 0, 0, 'alpha', 0), 65536)
GObject: <GObjectProxyModule <IntrospectionModule 'GObject' from '/usr/lib64/girepository-1.0/GObject-2.0.typelib'>>
__warningregistry__: {'version': 126, ("LightDM was imported without specifying a version first. Use gi.require_version('LightDM', '1') before import to ensure that the right version gets loaded.", <class 'gi.PyGIWarning'>, 10): True, ('GObject.MainLoop is deprecated; use GLib.MainLoop instead', <class 'gi.PyGIDeprecationWarning'>, 26): True, ('LightDM.Greeter.connect_sync is deprecated', <class 'DeprecationWarning'>, 33): True}
LightDM: <IntrospectionModule 'LightDM' from '/usr/lib64/girepository-1.0/LightDM-1.typelib'>
sys: <module 'sys' (built-in)>
greeter: <LightDM.Greeter object at 0x7f67c5485990 (LightDMGreeter at 0x557bbc8c4090)>
authentication_complete_cb: <function authentication_complete_cb at 0x7f67c8985e18>
main_loop: <GLib.MainLoop object at 0x7f67c54762e8 (GMainLoop at 0x557bbc8b9e20)>
Comment 1 pizza306 2017-06-24 09:27:43 EDT
Created attachment 1291497 [details]
File: backtrace
Comment 2 pizza306 2017-06-24 09:27:45 EDT
Created attachment 1291498 [details]
File: cgroup
Comment 3 pizza306 2017-06-24 09:27:46 EDT
Created attachment 1291499 [details]
File: cpuinfo
Comment 4 pizza306 2017-06-24 09:27:47 EDT
Created attachment 1291500 [details]
File: environ
Comment 5 pizza306 2017-06-24 09:27:49 EDT
Created attachment 1291501 [details]
File: mountinfo
Comment 6 pizza306 2017-06-24 09:27:50 EDT
Created attachment 1291502 [details]
File: namespaces
Comment 7 pizza306 2017-06-24 09:27:52 EDT
Created attachment 1291503 [details]
File: open_fds
Comment 8 Neal Gompa 2017-07-09 21:35:44 EDT
It looks like lightdm-autologin-greeter is not configured. Please follow the directions in /usr/share/doc/lightdm-autologin-greeter/README.distro for information on how to configure it.

Note You need to log in before you can comment on or make changes to this bug.