Bug 1464802 - qemu guest fails to start with "unknown CPU feature invtsc" after 7.3->7.4 upgrade [NEEDINFO]
qemu guest fails to start with "unknown CPU feature invtsc" after 7.3->7.4 up...
Status: CLOSED DUPLICATE of bug 1464804
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt (Show other bugs)
7.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Libvirt Maintainers
Virtualization Bugs
virt
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-25 18:41 EDT by Igor Netkachev
Modified: 2017-06-26 02:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-26 02:44:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
xuzhang: needinfo? (inetkach)


Attachments (Terms of Use)

  None (edit)
Description Igor Netkachev 2017-06-25 18:41:45 EDT
Description of problem:
qemu guest fails to start with "unknown CPU feature invtsc" after 7.3->7.4 upgrade


Version-Release number of selected component (if applicable):
RHEL 7.4

libvirt-3.2.0-9.el7.x86_64                                  Thu Jun 15 16:42:55 2017
libvirt-client-3.2.0-9.el7.x86_64                           Thu Jun 15 16:42:13 2017
libvirt-daemon-3.2.0-9.el7.x86_64                           Thu Jun 15 16:42:54 2017
libvirt-daemon-config-network-3.2.0-9.el7.x86_64            Thu Jun 15 16:42:54 2017
libvirt-daemon-config-nwfilter-3.2.0-9.el7.x86_64           Thu Jun 15 16:42:55 2017
libvirt-daemon-driver-interface-3.2.0-9.el7.x86_64          Thu Jun 15 16:42:54 2017
libvirt-daemon-driver-lxc-3.2.0-9.el7.x86_64                Thu Jun 15 16:42:54 2017
libvirt-daemon-driver-network-3.2.0-9.el7.x86_64            Thu Jun 15 16:42:54 2017
libvirt-daemon-driver-nodedev-3.2.0-9.el7.x86_64            Thu Jun 15 16:42:54 2017
libvirt-daemon-driver-nwfilter-3.2.0-9.el7.x86_64           Thu Jun 15 16:42:55 2017
libvirt-daemon-driver-qemu-3.2.0-9.el7.x86_64               Thu Jun 15 16:42:54 2017
libvirt-daemon-driver-secret-3.2.0-9.el7.x86_64             Thu Jun 15 16:42:54 2017
libvirt-daemon-driver-storage-3.2.0-9.el7.x86_64            Thu Jun 15 16:42:55 2017
libvirt-daemon-driver-storage-core-3.2.0-9.el7.x86_64       Thu Jun 15 16:42:54 2017
libvirt-daemon-driver-storage-disk-3.2.0-9.el7.x86_64       Thu Jun 15 16:42:54 2017
libvirt-daemon-driver-storage-gluster-3.2.0-9.el7.x86_64    Thu Jun 15 16:42:54 2017
libvirt-daemon-driver-storage-iscsi-3.2.0-9.el7.x86_64      Thu Jun 15 16:42:54 2017
libvirt-daemon-driver-storage-logical-3.2.0-9.el7.x86_64    Thu Jun 15 16:42:54 2017
libvirt-daemon-driver-storage-mpath-3.2.0-9.el7.x86_64      Thu Jun 15 16:42:55 2017
libvirt-daemon-driver-storage-rbd-3.2.0-9.el7.x86_64        Thu Jun 15 16:42:55 2017
libvirt-daemon-driver-storage-scsi-3.2.0-9.el7.x86_64       Thu Jun 15 16:42:54 2017
libvirt-daemon-kvm-3.2.0-9.el7.x86_64                       Thu Jun 15 16:43:20 2017
libvirt-gconfig-1.0.0-1.el7.x86_64                          Mon Jun 12 07:42:43 2017
libvirt-glib-1.0.0-1.el7.x86_64                             Mon Jun 12 07:44:05 2017
libvirt-gobject-1.0.0-1.el7.x86_64                          Mon Jun 12 07:44:05 2017
libvirt-libs-3.2.0-9.el7.x86_64                             Thu Jun 15 16:42:13 2017
libvirt-python-3.2.0-2.el7.x86_64                           Mon Jun 12 07:44:06 2017
qemu-guest-agent-2.8.0-2.el7.x86_64                         Mon Jun 12 07:48:30 2017
qemu-img-1.5.3-140.el7.x86_64                               Thu Jun 15 16:42:12 2017
qemu-kvm-1.5.3-140.el7.x86_64                               Thu Jun 15 16:42:42 2017
qemu-kvm-common-1.5.3-140.el7.x86_64                        Thu Jun 15 16:42:42 2017
qemu-kvm-tools-1.5.3-140.el7.x86_64                         Thu Jun 15 16:44:39 2017
qemu-kvm-tpm-2.6.0-28.el7_3.9.2.x86_64                      Wed Apr 26 12:06:57 2017


How reproducible:
100%

Steps to Reproduce:
1. Upgrade OS on Lenovo W540 T470 hypervisor to 7.4
2. Try to boot existing VM

Actual results:
error: Failed to start domain Virtual_Client_RHEL_6-KVM
error: internal error: unknown CPU feature invtsc


Expected results:
Guest boots without any issues

Additional info:
Downgrade libvirt to below versions makes guest boot again.
  libvirt.x86_64 0:3.2.0-6.el7                                                                
  libvirt-client.x86_64 0:3.2.0-6.el7                                                         
  libvirt-daemon.x86_64 0:3.2.0-6.el7                                                         
  libvirt-daemon-config-network.x86_64 0:3.2.0-6.el7                                          
  libvirt-daemon-config-nwfilter.x86_64 0:3.2.0-6.el7                                         
  libvirt-daemon-driver-interface.x86_64 0:3.2.0-6.el7                                        
  libvirt-daemon-driver-lxc.x86_64 0:3.2.0-6.el7                                              
  libvirt-daemon-driver-network.x86_64 0:3.2.0-6.el7                                          
  libvirt-daemon-driver-nodedev.x86_64 0:3.2.0-6.el7                                          
  libvirt-daemon-driver-nwfilter.x86_64 0:3.2.0-6.el7                                         
  libvirt-daemon-driver-qemu.x86_64 0:3.2.0-6.el7                                             
  libvirt-daemon-driver-secret.x86_64 0:3.2.0-6.el7                                           
  libvirt-daemon-driver-storage.x86_64 0:3.2.0-6.el7                                          
  libvirt-daemon-driver-storage-core.x86_64 0:3.2.0-6.el7                                     
  libvirt-daemon-driver-storage-disk.x86_64 0:3.2.0-6.el7                                     
  libvirt-daemon-driver-storage-gluster.x86_64 0:3.2.0-6.el7                                  
  libvirt-daemon-driver-storage-iscsi.x86_64 0:3.2.0-6.el7                                    
  libvirt-daemon-driver-storage-logical.x86_64 0:3.2.0-6.el7                                  
  libvirt-daemon-driver-storage-mpath.x86_64 0:3.2.0-6.el7                                    
  libvirt-daemon-driver-storage-rbd.x86_64 0:3.2.0-6.el7                                      
  libvirt-daemon-driver-storage-scsi.x86_64 0:3.2.0-6.el7                                     
  libvirt-daemon-kvm.x86_64 0:3.2.0-6.el7                                                     
  libvirt-gconfig.x86_64 0:0.2.3-1.el7                                                        
  libvirt-glib.x86_64 0:0.2.3-1.el7                                                           
  libvirt-gobject.x86_64 0:0.2.3-1.el7                                                        
  libvirt-libs.x86_64 0:3.2.0-6.el7                                                           
  libvirt-python.x86_64 0:2.0.0-2.el7

--
Kind Regards,
Igor Netkachev
Technical Support Engineer
Red Hat Global Support Services
Comment 1 Xuesong Zhang 2017-06-25 23:04:37 EDT
hi, Igor Netkachev,

It seems this BZ is same with BZ1464804, if yes, I'd like to close this one as duplicated BZ.
Comment 2 Peter Krempa 2017-06-26 02:44:07 EDT

*** This bug has been marked as a duplicate of bug 1464804 ***

Note You need to log in before you can comment on or make changes to this bug.