Bug 1464830 - rpmbuild --rebuild libusnic_verbs-2.0.1-5.el7.src.rpm failed
rpmbuild --rebuild libusnic_verbs-2.0.1-5.el7.src.rpm failed
Status: NEW
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libusnic_verbs (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Jarod Wilson
Infiniband QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-25 21:59 EDT by zguo
Modified: 2017-07-25 14:35 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zguo 2017-06-25 21:59:09 EDT
Description of problem:


Version-Release number of selected component (if applicable):
.qa.[root@x86-64-7w-v1 tps]# hostname
x86-64-7w-v1.ss.eng.bos.redhat.com
libusnic_verbs-2.0.1-5.el7.src.rpm


How reproducible:
Always

Steps to Reproduce:

[root@rdma-qe-08 ~]$ rpmbuild --rebuild libusnic_verbs-2.0.1-5.el7.src.rpm 
Installing libusnic_verbs-2.0.1-5.el7.src.rpm
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.4BaTuE
+ umask 022
+ cd /root/rpmbuild/BUILD
+ cd /root/rpmbuild/BUILD
+ rm -rf libusnic_verbs-2.0.1
+ /usr/bin/bzip2 -dc /root/rpmbuild/SOURCES/libusnic_verbs-2.0.1.tar.bz2
+ /usr/bin/tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd libusnic_verbs-2.0.1
+ /usr/bin/bzip2 -dc /root/rpmbuild/SOURCES/usnic-tools-1.1.1.0.tar.bz2
+ /usr/bin/tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ /usr/bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.z2OuJ1
+ umask 022
+ cd /root/rpmbuild/BUILD
+ cd libusnic_verbs-2.0.1
+ CFLAGS='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches   -m64 -mtune=generic'
+ export CFLAGS
+ CXXFLAGS='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches   -m64 -mtune=generic'
+ export CXXFLAGS
+ FFLAGS='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches   -m64 -mtune=generic -I/usr/lib64/gfortran/modules'
+ export FFLAGS
+ FCFLAGS='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches   -m64 -mtune=generic -I/usr/lib64/gfortran/modules'
+ export FCFLAGS
+ LDFLAGS='-Wl,-z,relro '
+ export LDFLAGS
+ '[' 1 == 1 ']'
+ '[' x86_64 == ppc64le ']'
++ find . -name config.guess -o -name config.sub
+ for i in '$(find . -name config.guess -o -name config.sub)'
++ basename ./config/config.sub
+ '[' -f /usr/lib/rpm/redhat/config.sub ']'
+ /usr/bin/rm -f ./config/config.sub
++ basename ./config/config.sub
+ /usr/bin/cp -fv /usr/lib/rpm/redhat/config.sub ./config/config.sub
'/usr/lib/rpm/redhat/config.sub' -> './config/config.sub'
+ for i in '$(find . -name config.guess -o -name config.sub)'
++ basename ./config/config.guess
+ '[' -f /usr/lib/rpm/redhat/config.guess ']'
+ /usr/bin/rm -f ./config/config.guess
++ basename ./config/config.guess
+ /usr/bin/cp -fv /usr/lib/rpm/redhat/config.guess ./config/config.guess
'/usr/lib/rpm/redhat/config.guess' -> './config/config.guess'
+ for i in '$(find . -name config.guess -o -name config.sub)'
++ basename ./usnic-tools-1.1.1.0/config/config.sub
+ '[' -f /usr/lib/rpm/redhat/config.sub ']'
+ /usr/bin/rm -f ./usnic-tools-1.1.1.0/config/config.sub
++ basename ./usnic-tools-1.1.1.0/config/config.sub
+ /usr/bin/cp -fv /usr/lib/rpm/redhat/config.sub ./usnic-tools-1.1.1.0/config/config.sub
'/usr/lib/rpm/redhat/config.sub' -> './usnic-tools-1.1.1.0/config/config.sub'
+ for i in '$(find . -name config.guess -o -name config.sub)'
++ basename ./usnic-tools-1.1.1.0/config/config.guess
+ '[' -f /usr/lib/rpm/redhat/config.guess ']'
+ /usr/bin/rm -f ./usnic-tools-1.1.1.0/config/config.guess
++ basename ./usnic-tools-1.1.1.0/config/config.guess
+ /usr/bin/cp -fv /usr/lib/rpm/redhat/config.guess ./usnic-tools-1.1.1.0/config/config.guess
'/usr/lib/rpm/redhat/config.guess' -> './usnic-tools-1.1.1.0/config/config.guess'
+ ./configure --build=x86_64-redhat-linux-gnu --host=x86_64-redhat-linux-gnu --program-prefix= --disable-dependency-tracking --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib64 --libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/var/lib --mandir=/usr/share/man --infodir=/usr/share/info --with-release=1.1.1.0 --with-valgrind
configure: WARNING: unrecognized options: --with-release, --with-valgrind
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /usr/bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether make supports nested variables... (cached) yes
checking for style of include used by make... GNU
checking for x86_64-redhat-linux-gnu-gcc... no
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... none
checking for gcc option to accept ISO C99... -std=gnu99
checking for x86_64-redhat-linux-gnu-ar... no
checking for x86_64-redhat-linux-gnu-lib... no
checking for x86_64-redhat-linux-gnu-link... no
checking for ar... ar
checking the archiver (ar) interface... ar
checking build system type... x86_64-redhat-linux-gnu
checking host system type... x86_64-redhat-linux-gnu
checking how to print strings... printf
checking for a sed that does not truncate output... /usr/bin/sed
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for fgrep... /usr/bin/grep -F
checking for ld used by gcc -std=gnu99... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 3458764513820540925
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking how to convert x86_64-redhat-linux-gnu file names to x86_64-redhat-linux-gnu format... func_convert_file_noop
checking how to convert x86_64-redhat-linux-gnu file names to toolchain format... func_convert_file_noop
checking for /usr/bin/ld option to reload object files... -r
checking for x86_64-redhat-linux-gnu-objdump... no
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for x86_64-redhat-linux-gnu-dlltool... no
checking for dlltool... no
checking how to associate runtime and link libraries... printf %s\n
checking for x86_64-redhat-linux-gnu-ar... ar
checking for archiver @FILE support... @
checking for x86_64-redhat-linux-gnu-strip... no
checking for strip... strip
checking for x86_64-redhat-linux-gnu-ranlib... no
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -B output from gcc -std=gnu99 object... ok
checking for sysroot... no
checking for x86_64-redhat-linux-gnu-mt... no
checking for mt... no
checking if : is a manifest tool... no
checking how to run the C preprocessor... gcc -std=gnu99 -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if gcc -std=gnu99 supports -fno-rtti -fno-exceptions... no
checking for gcc -std=gnu99 option to produce PIC... -fPIC -DPIC
checking if gcc -std=gnu99 PIC flag -fPIC -DPIC works... yes
checking if gcc -std=gnu99 static flag -static works... no
checking if gcc -std=gnu99 supports -c -o file.o... yes
checking if gcc -std=gnu99 supports -c -o file.o... (cached) yes
checking whether the gcc -std=gnu99 linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking for shl_load... no
checking for shl_load in -ldld... no
checking for dlopen... no
checking for dlopen in -ldl... yes
checking whether a program can dlopen itself... yes
checking whether a statically linked program can dlopen itself... yes
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
checking for ibv_get_device_list in -libverbs... yes
checking infiniband/driver.h usability... no
checking infiniband/driver.h presence... no
checking for infiniband/driver.h... no
configure: error: <infiniband/driver.h> not found.  libusnic_verbs requires libibverbs.
error: Bad exit status from /var/tmp/rpm-tmp.z2OuJ1 (%build)


RPM build errors:
    user mockbuild does not exist - using root
    group mockbuild does not exist - using root
    user mockbuild does not exist - using root
    group mockbuild does not exist - using root
    user mockbuild does not exist - using root
    group mockbuild does not exist - using root
    Bad exit status from /var/tmp/rpm-tmp.z2OuJ1 (%build)
[root@rdma-qe-08 ~]$ rpm -qa | grep libibverbs
libibverbs-13-7.el7.x86_64
libibverbs-utils-13-7.el7.x86_64

[root@rdma-qe-08 ~]$ uname -r
3.10.0-685.el7.x86_64
[root@rdma-qe-08 ~]$ cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.4 Beta (Maipo)
[root@rdma-qe-08 ~]$ cat /etc/motd |grep DISTRO
                           DISTRO=RHEL-7.4-20170621.0

Expected results:
rpmbuild --rebuild libusnic_verbs-2.0.1-5.el7.src.rpm passed without error
Additional info:
Comment 2 Honggang LI 2017-06-26 02:40:45 EDT
> checking for infiniband/driver.h... no
> configure: error: <infiniband/driver.h> not found.  libusnic_verbs requires libibverbs.
> error: Bad exit status from /var/tmp/rpm-tmp.z2OuJ1 (%build)

/usr/include/infiniband/driver.h was provided by libibverbs-devel. This header file still exist in upstream rdma-core repo. The header file had been removed when rebase rdma-core-13-1.el7.
Comment 3 Jarod Wilson 2017-07-13 10:46:56 EDT
Problem persists in current latest upstream libusnic_verbs as well, cc'ing in Cisco's maintainer, no clue yet if this is just a trivial fix or more involved.
Comment 4 Jarod Wilson 2017-07-13 10:52:06 EDT
(In reply to Honggang LI from comment #2)
> > checking for infiniband/driver.h... no
> > configure: error: <infiniband/driver.h> not found.  libusnic_verbs requires libibverbs.
> > error: Bad exit status from /var/tmp/rpm-tmp.z2OuJ1 (%build)
> 
> /usr/include/infiniband/driver.h was provided by libibverbs-devel. This
> header file still exist in upstream rdma-core repo. The header file had been
> removed when rebase rdma-core-13-1.el7.

Yes, driver.h does still exist in the rdma-core repo, but it's clearly and intentionally marked as an internal header now, not to be used by anything outside the rdma-core tree. (See: libibverbs/CMakeLists.txt in the rdma-core source tree).
Comment 5 Jeff Squyres 2017-07-14 15:50:09 EDT
I've filed upstream issue: https://github.com/cisco/libusnic_verbs/issues/7

Let me see if I can get a fix to you today.
Comment 6 Jeff Squyres 2017-07-14 17:59:22 EDT
Closed this as "won't fix" in https://github.com/cisco/libusnic_verbs/issues/7#issuecomment-315477871.

Here's the deal:

Per the commit message in the first commit in the libusnic_verbs repo (https://github.com/cisco/libusnic_verbs/commit/222dabc5c448180c54507a547ea1fa3198cbd2c1), the libusnic_verbs package is only for legacy versions of libibverbs.  Newer versions of libibverbs do not need this plugin, because they will not emit a spurious error message about devices in the kernel that do not have a matching provider in libibverbs.  Hence, the if the "rdma-core" / newer generation of libibverbs is being used, then this plugin is not required (and should not be used).

Meaning: this plugin will not build against rdma-core, and that's ok.  Since RHEL 7.4 is apparently using rdma-core, then RHEL 7.4 can drop the libusnic_verbs package.

Make sense?
Comment 7 Jarod Wilson 2017-07-21 17:45:32 EDT
Yeah, that makes sense to me. We're currently still shipping libusnic_verbs, I suppose we could just Obsoletes: it via rdma-core?
Comment 8 Jeff Squyres 2017-07-25 14:35:30 EDT
@Jarod: Yes, that makes sense to me.

Note You need to log in before you can comment on or make changes to this bug.