Bug 146497 - Ruby 1.8.2 missing xml-parsing library files
Ruby 1.8.2 missing xml-parsing library files
Status: CLOSED DUPLICATE of bug 146387
Product: Fedora
Classification: Fedora
Component: ruby (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Bill Huang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-28 16:06 EST by Ariel Segall
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:08:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ariel Segall 2005-01-28 16:06:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
The ruby package downloading using "yum install ruby" was missing
several files. I discovered this when trying to run instiki. Ruby
produced errors of "XML parser module not found". The xsd/xmlparser
file relied upon one of xml/parser (does not exist), xmlscan/scanner
(does not exist), or rexml. Rexml was installed, but was missing
seemingly random files that caused the library to break;
rexml/namespace, in particular, was expected but did not exist,
although rexml/validation, rexml/parent, rexml/cdata,
rexml/parseexception, and rexml/xpath did.
(All references are to the default install directory /usr/lib/ruby/1.8/)

It appears that the default ruby install's rexml library is broken.

Version-Release number of selected component (if applicable):
ruby-1.8.2-1.FC3.0

How reproducible:
Always

Steps to Reproduce:
1.From blank Fedora install, yum install ruby
2.Download instiki (instiki.org)
3.ruby instiki
4. Follow error message trail
    

Additional info:
Comment 1 Ariel Segall 2005-01-28 16:09:30 EST

*** This bug has been marked as a duplicate of 146387 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:08:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.