Bug 1464971 - Kibana not opening - SearchGuard no data for [NEEDINFO]
Kibana not opening - SearchGuard no data for
Status: CLOSED DUPLICATE of bug 1449378
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging (Show other bugs)
3.4.1
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Jeff Cantrill
Xia Zhao
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-26 06:25 EDT by Ruben Romero Montes
Modified: 2017-06-28 11:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-28 09:49:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pportant: needinfo? (bvincell)


Attachments (Terms of Use)
logging-es and kibana logs (3.74 KB, application/x-xz)
2017-06-26 06:25 EDT, Ruben Romero Montes
no flags Details

  None (edit)
Description Ruben Romero Montes 2017-06-26 06:25:02 EDT
Created attachment 1291942 [details]
logging-es and kibana logs

Description of problem:
Unable to open the Discover page in Kibana.

Version-Release number of selected component (if applicable):
3.4.1

How reproducible:
Unknown

Steps to Reproduce:
1. Install EFK stack
2. Try to access Kibana either directly or from "View Archive"

Actual results:
Unable to access Kibana. Page timeouts while loading

Expected results:
Display the Discovery page in Kibana

Additional info:

See the following logs for pod logging-es-80njvkm1-3-jvxvz
[2017-06-23 16:08:40,782][ERROR][com.floragunn.searchguard.configuration.ConfigurationLoader] No data for config while retrieving configuration for [config, roles, rolesmapping, actiongroups]  (index=.searchguard.logging-es-80njvkm1-3-jvxvz)
[2017-06-23 16:08:40,782][ERROR][com.floragunn.searchguard.configuration.ConfigurationLoader] No data for roles while retrieving configuration for [config, roles, rolesmapping, actiongroups]  (index=.searchguard.logging-es-80njvkm1-3-jvxvz)
[2017-06-23 16:08:40,782][ERROR][com.floragunn.searchguard.configuration.ConfigurationLoader] No data for rolesmapping while retrieving configuration for [config, roles, rolesmapping, actiongroups]  (index=.searchguard.logging-es-80njvkm1-3-jvxvz)
[2017-06-23 16:08:40,782][ERROR][com.floragunn.searchguard.configuration.ConfigurationLoader] No data for actiongroups while retrieving configuration for [config, roles, rolesmapping, actiongroups]  (index=.searchguard.logging-es-80njvkm1-3-jvxvz)
[2017-06-23 16:08:40,921][ERROR][com.floragunn.searchguard.configuration.ConfigurationLoader] No data for config while retrieving configuration for [config, roles, rolesmapping, actiongroups]  (index=.searchguard.logging-es-80njvkm1-3-jvxvz)
[2017-06-23 16:08:40,921][ERROR][com.floragunn.searchguard.configuration.ConfigurationLoader] No data for roles while retrieving configuration for [config, roles, rolesmapping, actiongroups]  (index=.searchguard.logging-es-80njvkm1-3-jvxvz)
[2017-06-23 16:08:40,921][ERROR][com.floragunn.searchguard.configuration.ConfigurationLoader] No data for rolesmapping while retrieving configuration for [config, roles, rolesmapping, actiongroups]  (index=.searchguard.logging-es-80njvkm1-3-jvxvz)
[2017-06-23 16:08:40,921][ERROR][com.floragunn.searchguard.configuration.ConfigurationLoader] No data for actiongroups while retrieving configuration for [config, roles, rolesmapping, actiongroups]  (index=.searchguard.logging-es-80njvkm1-3-jvxvz)

It also happens in pod logging-es-54saglv2-3-hhqep
[2017-06-23 16:08:40,788][ERROR][com.floragunn.searchguard.configuration.ConfigurationLoader] No data for actiongroups while retrieving configuration for [config, roles, rolesmapping, actiongroups]  (index=.searchguard.logging-es-54saglv2-3-hhqep)

But not for the other pod logging-es-q07h8j30-4-4tsl1
[2017-06-23 16:08:39,104][INFO ][cluster.metadata         ] [Angela Del Toro] [.searchguard.logging-es-q07h8j30-4-4tsl1] create_mapping [config]
[2017-06-23 16:08:40,264][INFO ][cluster.metadata         ] [Angela Del Toro] [.searchguard.logging-es-q07h8j30-4-4tsl1] create_mapping [roles]
[2017-06-23 16:08:40,470][INFO ][cluster.metadata         ] [Angela Del Toro] [.searchguard.logging-es-54saglv2-3-hhqep] create_mapping [config]
[2017-06-23 16:08:40,471][INFO ][cluster.metadata         ] [Angela Del Toro] [.searchguard.logging-es-q07h8j30-4-4tsl1] create_mapping [rolesmapping]
[2017-06-23 16:08:40,648][INFO ][cluster.metadata         ] [Angela Del Toro] [.searchguard.logging-es-q07h8j30-4-4tsl1] create_mapping [actiongroups]
[2017-06-23 16:08:40,650][INFO ][cluster.metadata         ] [Angela Del Toro] [.searchguard.logging-es-54saglv2-3-hhqep] create_mapping [roles]
[2017-06-23 16:08:40,747][INFO ][cluster.metadata         ] [Angela Del Toro] [.searchguard.logging-es-54saglv2-3-hhqep] create_mapping [rolesmapping]
[2017-06-23 16:08:40,829][INFO ][cluster.metadata         ] [Angela Del Toro] [.searchguard.logging-es-54saglv2-3-hhqep] create_mapping [actiongroups]
[2017-06-23 16:08:43,166][INFO ][cluster.metadata         ] [Angela Del Toro] [.searchguard.logging-es-80njvkm1-3-jvxvz] create_mapping [config]
[2017-06-23 16:08:43,414][INFO ][cluster.metadata         ] [Angela Del Toro] [.searchguard.logging-es-80njvkm1-3-jvxvz] create_mapping [roles]
[2017-06-23 16:08:43,711][INFO ][cluster.metadata         ] [Angela Del Toro] [.searchguard.logging-es-80njvkm1-3-jvxvz] create_mapping [rolesmapping]
[2017-06-23 16:08:43,819][INFO ][cluster.metadata         ] [Angela Del Toro] [.searchguard.logging-es-80njvkm1-3-jvxvz] create_mapping [actiongroups]
Comment 1 Ruben Romero Montes 2017-06-26 12:17:15 EDT
After scaling down and deleting manually all the files, the behaviour persists.
Comment 3 Jeff Cantrill 2017-06-28 09:49:12 EDT
Closing as a dup since this is because the SG perms are not seeded properly.  There is a fix to be backported to 3.4 to resolve.

*** This bug has been marked as a duplicate of bug 1449378 ***
Comment 4 Peter Portante 2017-06-28 11:42:41 EDT
This second set of logs seems to show that logging is working fine, but the second set of logs was captured too quickly after ES pods were started.  If we could get an update on this problem, if it is still a problem, that would be great.

Note You need to log in before you can comment on or make changes to this bug.