Bug 14650 - [bind-utils] host command doesn't resolve ip properly
[bind-utils] host command doesn't resolve ip properly
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-25 21:42 EDT by Enrico Scholz
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-03 11:39:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2000-07-25 21:42:47 EDT
When using the 'host' command with a not fully qualified name of a host
outside the own domain, its ip will not be printed (see example below)

This is a bad behavior because the manpage of host(1) says:
------------
DESCRIPTION
... By default, it simply converts between host names and Internet
addresses. ...
------------

The error will be caused by the 2nd hunk of the `bind-8.8.2p5-hostmx.patch'
patchfile in the src.rpm.



Example:
-------------
$ host mailbox 
$ host -ta mailbox
mailbox.hrz.tu-chemnitz.de has address 134.109.132.125
$ host mailbox.hrz.tu-chemnitz.de
mailbox.hrz.tu-chemnitz.de has address 134.109.132.125

$ cat /etc/resolv.conf
domain ultra.csn.tu-chemnitz.de
search ultra.csn.tu-chemnitz.de csn.tu-chemnitz.de tu-chemnitz.de
hrz.tu-chemnitz.de informatik.tu-chemnitz.de
nameserver 192.168.5.1 
$
--------------
Comment 1 Enrico Scholz 2000-07-25 22:19:03 EDT
This bug is the opposite of #9021, so the error seems to lie deeply in bind...
Comment 2 Bernhard Rosenkraenzer 2000-08-02 12:06:23 EDT
Can't reproduce it...

[bero@bero bero]$ host ftp
ftp.redhat.de is a nichname for ns.redhat.de
ns.redhat.de has address 193.103.254.150
ns.redhat.de has address 193.103.254.150
[bero@bero bero]$ host www
www.redhat.de has address 193.103.254.129
www.redhat.de mail is handled (pri=100) by mail.de.uu.net
www.redhat.de mail is handled (pri=5) by mail.redhat.de
www.redhat.de mail is handled (pri=10) by mail.redhat.com
[bero@bero bero]$ rpm -q bind-utils
bind-utils-8.2.2_P5-24
Comment 3 Enrico Scholz 2000-08-03 11:00:56 EDT
I have verified the described behavior again on another machine:

Try to add `redhat.com' into the `search' list of /etc/resolv.conf (but *not* as
the first entry).

$ host beta
beta.redhat.com is a nickname for gribble.redhat.com
gribble.redhat.com mail is handled (pri=10) by mail.redhat.com
gribble.redhat.com mail is handled (pri=10) by mail.redhat.com
$ host -ta beta
beta.redhat.com is a nickname for gribble.redhat.com
gribble.redhat.com has address 199.183.24.203
gribble.redhat.com has address 199.183.24.203


When adding `redhat.com' as first entry into the searchlist, I get the correct
answer:

$ host beta
beta.redhat.com is a nickname for gribble.redhat.com
gribble.redhat.com has address 199.183.24.203
gribble.redhat.com has address 199.183.24.203
$
Comment 4 Bernhard Rosenkraenzer 2000-08-03 11:39:39 EDT
I can reproduce it when the domain is not the first one listed in search...
Looking into it.
Comment 5 Enrico Scholz 2000-10-13 10:13:21 EDT
Fixed in bind-9.0.0-1

Note You need to log in before you can comment on or make changes to this bug.