Bug 1465062 - perl-pmtools-2.0.0-8.fc27 FTBFS: Failed test 'catted module function'
perl-pmtools-2.0.0-8.fc27 FTBFS: Failed test 'catted module function'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-pmtools (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
https://apps.fedoraproject.org/kosche...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-26 10:17 EDT by Petr Pisar
Modified: 2017-07-20 09:33 EDT (History)
3 users (show)

See Also:
Fixed In Version: perl-pmtools-2.0.0-9.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-20 09:33:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 122210 None None None 2017-06-26 10:20 EDT

  None (edit)
Description Petr Pisar 2017-06-26 10:17:18 EDT
perl-pmtools-2.0.0-8.fc27 fails to build in F27 because a test fails:

t/modpods.t ...... ok
#   Failed test 'catted module function'
#   at t/pfcat.t line 19.
#                   'Name "Config::Config" used only once: possible typo at blib/script/podgrep line 38.
# =head1 /usr/share/perl5/pod/perlfunc.pod chunk 40
# 
# L<C<binmode>|/binmode FILEHANDLE, LAYER>, L<C<close>|/close FILEHANDLE>,
# L<C<closedir>|/closedir DIRHANDLE>, L<C<dbmclose>|/dbmclose HASH>,
[...]
# The position in the file of FILEHANDLE is left unchanged.  You may want to
# call L<seek|/"seek FILEHANDLE,POSITION,WHENCE"> before writing to the
# file.
# 
# '
#     doesn't match '(?^:There is no .*systell.* function.\s+Use .*sysseek)'
t/pfcat.t ........ 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/2 subtests 
# Looks like you failed 1 test of 2.

A difference between working and failing build root is:

perl-ExtUtils-MakeMaker 	7.28-1.fc27 	> 	1:7.28-2.fc27
	perl-libs 	4:5.24.1-391.fc27 	> 	4:5.26.0-393.fc27
	perl-Test-Simple 	1.302085-1.fc27 	> 	1:1.302085-2.fc27
	perl-perlfaq 	5.021011-3.fc26 	> 	5.021011-393.fc27
	perl-generators 	1.10-2.fc26 	> 	1.10-4.fc27
	perl 	4:5.24.1-391.fc27 	> 	4:5.26.0-393.fc27
	perl-Carp 	1.42-1.fc27 	> 	1.42-393.fc27
	perl-PathTools 	3.67-1.fc27 	> 	3.67-393.fc27
	perl-constant 	1.33-368.fc26 	> 	1.33-394.fc27
	perl-Getopt-Long 	2.50-1.fc27 	> 	1:2.50-2.fc27
	perl-ExtUtils-Manifest 	1.70-366.fc26 	> 	1.70-393.fc27
	perl-Pod-Usage 	4:1.69-2.fc26 	> 	4:1.69-393.fc27
	perl-version 	5:0.99.18-1.fc27 	> 	6:0.99.18-3.fc27
	perl-ExtUtils-ParseXS 	1:3.34-1.fc27 	> 	1:3.34-393.fc27
	perl-File-Path 	2.13-1.fc27 	> 	2.13-2.fc27
	perl-threads 	1:2.16-1.fc27 	> 	1:2.16-2.fc27
	perl-ExtUtils-Install 	2.14-1.fc27 	> 	2.14-2.fc27
	perl-Text-ParseWords 	3.30-366.fc26 	> 	3.30-393.fc27
	perl-Scalar-List-Utils 	3:1.47-2.fc26 	> 	3:1.47-3.fc27
	perl-Fedora-VSP 	0.001-5.fc26 	> 	0.001-7.fc27
	perl-File-Temp 	0.230.400-2.fc26 	> 	0.230.400-393.fc27
	perl-podlators 	4.09-2.fc26 	> 	4.09-393.fc27
	perl-Exporter 	5.72-367.fc26 	> 	5.72-394.fc27
	perl-devel 	4:5.24.1-391.fc27 	> 	4:5.26.0-393.fc27
	perl-Data-Dumper 	2.167-1.fc27 	> 	2.167-394.fc27
	perl-Storable 	1:2.62-1.fc27 	> 	1:2.62-393.fc27
	perl-Test-Harness 	3.39-1.fc27 	> 	1:3.39-3.fc27
	perl-Term-ANSIColor 	4.06-3.fc27 	> 	4.06-394.fc27
	perl-Encode 	4:2.89-7.fc27 	> 	4:2.89-8.fc27
	perl-macros 	4:5.24.1-391.fc27 	> 	4:5.26.0-393.fc27
	perl-Text-Tabs+Wrap 	2013.0523-366.fc26 	> 	2013.0523-393.fc27
	perl-threads-shared 	1.57-1.fc27 	> 	1.57-2.fc27
	perl-IO 	1.36-391.fc27 	> 	1.38-393.fc27
	perl-ExtUtils-Command 	7.28-1.fc27 	> 	1:7.28-2.fc27
	perl-parent 	1:0.236-2.fc26 	> 	1:0.236-393.fc27
	perl-Unicode-Normalize 	1.25-367.fc27 	> 	1.25-393.fc27
	perl-Pod-Perldoc 	3.28-1.fc27 	> 	3.28-394.fc27
	perl-Errno 	1.25-391.fc27 	> 	1.28-393.fc27
	perl-Pod-Simple 	1:3.35-2.fc26 	> 	1:3.35-393.fc27
	perl-Socket 	4:2.024-2.fc26 	> 	4:2.024-3.fc27
	libdb-devel 	5.3.28-21.fc27 	> 	5.3.28-22.fc27
	perl-Term-Cap 	1.17-366.fc26 	> 	1.17-393.fc27
	perl-MIME-Base64 	3.15-366.fc26 	> 	3.15-393.fc27
	libdb 	5.3.28-21.fc27 	> 	5.3.28-22.fc27
	perl-Pod-Escapes 	1:1.07-366.fc26 	> 	1:1.07-393.fc27
	perl-HTTP-Tiny 	0.070-2.fc26 	> 	0.070-393.fc27
	libdb-utils 	5.3.28-21.fc27 	> 	5.3.28-22.fc27
	openldap 	2.4.44-10.fc27 	> 	2.4.44-11.fc27
	perl-Time-Local 	1:1.250-2.fc26 	> 	1:1.250-393.fc27
	libipt 	1.5-2.fc26 	> 	1.6.1-2.fc27
	gdb-headless 	7.99.90.20170420-12.fc27 	> 	8.0-13.fc27
	perl-srpm-macros 	1-21.fc26 	> 	1-23.fc27
	kernel-headers 	4.12.0-0.rc4.git2.1.... 	> 	4.12.0-0.rc4.git3.1....
	binutils 	2.28-7.fc27 	> 	2.28-8.fc27
Comment 1 Petr Pisar 2017-06-26 10:20:25 EDT
Debian posted a fix for a change in Perl 5.26.0 POD wording.
Comment 2 Petr Pisar 2017-07-20 09:18:10 EDT
I will apply the Debian patch.

Note You need to log in before you can comment on or make changes to this bug.