Bug 1465270 - [3.3]Failed to upgrade ocp due to detected available excluder version is not expected
[3.3]Failed to upgrade ocp due to detected available excluder version is not ...
Status: CLOSED WONTFIX
Product: OpenShift Container Platform
Classification: Red Hat
Component: Upgrade (Show other bugs)
3.3.1
Unspecified Unspecified
medium Severity medium
: ---
: 3.3.1
Assigned To: Scott Dodson
Anping Li
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-27 01:09 EDT by liujia
Modified: 2017-08-21 22:56 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-21 08:43:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description liujia 2017-06-27 01:09:22 EDT
Description of problem:
Failed to upgrade ocp3.2 to ocp3.3 with openshift_release set to v3.3 due to detected available excluder version is not expected when there are higher version repo on the hosts.

TASK [openshift_excluder : Check the available atomic-openshift-docker-excluder version is at most of the upgrade target version] ***
task path: /usr/share/ansible/openshift-ansible/roles/openshift_excluder/tasks/verify_excluder.yml:27
fatal: [x.x.x.x]: FAILED! => {
    "changed": false, 
    "failed": true, 
    "invocation": {
        "module_args": {
            "msg": "Available atomic-openshift-docker-excluder version 3.4.1.44 is higher than the upgrade target version"
        }, 
        "module_name": "fail"
    }
}

MSG:

Available atomic-openshift-docker-excluder version 3.4.1.44 is higher than the upgrade target version
	to retry, use: --limit @/usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/upgrades/v3_3/upgrade.retry


Version-Release number of selected component (if applicable):
atomic-openshift-utils-3.3.101-1.git.0.abe8fc6.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. Install ocp3.2.
2. Edit inventory file(There are both v3.3 and v3.4 repo on the hosts)
openshift_release=v3.3
3. Upgrade 3.2 to 3.3
# ansible-playbook -i hosts /usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/upgrades/v3_3/upgrade.yml

Actual results:
Upgrade failed. 

Expected results:
Upgrade succeed.

Additional info:

Note You need to log in before you can comment on or make changes to this bug.