Bug 1465305 - Build perl-Moose for RHV 4.1
Build perl-Moose for RHV 4.1
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: distribution (Show other bugs)
4.1.4
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sandro Bonazzola
:
Depends On:
Blocks: 1464331
  Show dependency treegraph
 
Reported: 2017-06-27 03:32 EDT by Sandro Bonazzola
Modified: 2017-06-28 11:01 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-28 11:01:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sandro Bonazzola 2017-06-27 03:32:55 EDT
perl-Moose is a build dependency for perl-App-CSV needed by ovirt-log-collector.
EPEL build exist: https://dl.fedoraproject.org/pub/epel/7/SRPMS/p/perl-Moose-2.1005-1.el7.src.rpm
Comment 1 Sandro Bonazzola 2017-06-27 10:37:37 EDT
(In reply to Sandro Bonazzola from comment #0)
> perl-Moose is a build dependency for perl-App-CSV needed by
> ovirt-log-collector.
> EPEL build exist:
> https://dl.fedoraproject.org/pub/epel/7/SRPMS/p/perl-Moose-2.1005-1.el7.src.
> rpm

This version fails to build on:
Error: No Package found for perl(Algorithm::C3)
Error: No Package found for perl(CPAN::Meta::Check) >= 0.007
Error: No Package found for perl(DBM::Deep) >= 1.0003
Error: No Package found for perl(Data::Visitor)
Error: No Package found for perl(DateTime::Calendar::Mayan)
Error: No Package found for perl(DateTime::Format::MySQL)
Error: No Package found for perl(Declare::Constraints::Simple)
Error: No Package found for perl(Devel::GlobalDestruction)
Error: No Package found for perl(Eval::Closure) >= 0.04
Error: No Package found for perl(Locale::US)
Error: No Package found for perl(MRO::Compat) >= 0.05
Error: No Package found for perl(Module::Info)
Error: No Package found for perl(Module::Refresh)
Error: No Package found for perl(Params::Coerce)
Error: No Package found for perl(SUPER) >= 1.10
Error: No Package found for perl(Sub::Name) >= 0.05
Error: No Package found for perl(Test::CheckDeps) >= 0.006
Error: No Package found for perl(Test::Inline)
Error: No Package found for perl(Test::LeakTrace)

It will need some work.
Comment 2 Sandro Bonazzola 2017-06-28 11:01:15 EDT
ovirt-log-collector doesn't require anymore perl-App-CSV. Being this need only for building perl-App-CSV, i'm closing as wontfix.

Note You need to log in before you can comment on or make changes to this bug.