Bug 1465337 - [OVS] conntrack - SNAT with ct_mark change on reply FAILED (system-traffic.at:2470)
[OVS] conntrack - SNAT with ct_mark change on reply FAILED (system-traffic....
Status: CLOSED DUPLICATE of bug 1457439
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openvswitch (Show other bugs)
7.4
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Open vSwitch development team
ovs-qe@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-27 05:09 EDT by qding
Modified: 2017-06-27 08:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-27 08:49:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description qding 2017-06-27 05:09:55 EDT
Description of problem:

## ----------------------------- ##
## openvswitch 2.7.0 test suite. ##
## ----------------------------- ##

datapath-sanity

  1: datapath - ping between two ports               ok
  2: datapath - http between two ports               ok
  3: datapath - ping between two ports on vlan       ok
  4: datapath - ping between two ports on cvlan      ok
  5: datapath - ping6 between two ports              ok
  6: datapath - ping6 between two ports on vlan      ok
  7: datapath - ping6 between two ports on cvlan     ok
  8: datapath - ping over bond                       ok
  9: datapath - ping over vxlan tunnel               ok
 10: datapath - ping over gre tunnel                 ok
 11: datapath - ping over geneve tunnel              ok
 12: datapath - clone action                         ok
 13: datapath - basic truncate action                ok
 14: datapath - truncate and output to gre tunnel    ok

conntrack

 15: conntrack - controller                          ok
 16: conntrack - IPv4 ping                           ok
 17: conntrack - IPv6 ping                           ok
 18: conntrack - preserve registers                  ok
 19: conntrack - invalid                             ok
 20: conntrack - zones                               ok
 21: conntrack - zones from field                    ok
 22: conntrack - multiple bridges                    ok
 23: conntrack - multiple zones                      ok
 24: conntrack - multiple namespaces, internal ports ok
 25: conntrack - ct_mark                             ok
 26: conntrack - ct_mark bit-fiddling                ok
 27: conntrack - ct_mark from register               ok
 28: conntrack - ct_label                            ok
 29: conntrack - ct_label bit-fiddling               ok
 30: conntrack - ct metadata, multiple zones         ok
 31: conntrack - ICMP related                        ok
 32: conntrack - ICMP related 2                      ok
 33: conntrack - IPv4 fragmentation                  ok
 34: conntrack - IPv4 fragmentation expiry           ok
 35: conntrack - IPv4 fragmentation + vlan           ok
 36: conntrack - IPv4 fragmentation + cvlan          ok
 37: conntrack - IPv6 fragmentation                  ok
 38: conntrack - IPv6 fragmentation expiry           ok
 39: conntrack - IPv6 fragmentation + vlan           ok
 40: conntrack - IPv6 fragmentation + cvlan          ok
 41: conntrack - Fragmentation over vxlan            ok
 42: conntrack - IPv6 Fragmentation over vxlan       ok
 43: conntrack - resubmit to ct multiple times       ok

conntrack - L7

 44: conntrack - IPv4 HTTP                           ok
 45: conntrack - IPv6 HTTP                           ok
 46: conntrack - commit, recirc                      ok
 47: conntrack - multiple zones, local               ok
 48: conntrack - multi-stage pipeline, local         ok
 49: conntrack - FTP                                 skipped (system-traffic.at:2097)
 50: conntrack - FTP over IPv6                       skipped (system-traffic.at:2182)
 51: conntrack - FTP with multiple expectations      skipped (system-traffic.at:2237)
 52: conntrack - TFTP                                skipped (system-traffic.at:2303)

conntrack - NAT

 53: conntrack - simple SNAT                         ok
 54: conntrack - SNAT with ct_mark change on reply   FAILED (system-traffic.at:2470)
 55: conntrack - SNAT with port range                ok
 56: conntrack - more complex SNAT                   ok
 57: conntrack - simple DNAT                         ok
 58: conntrack - more complex DNAT                   ok
 59: conntrack - ICMP related with NAT               ok
 60: conntrack - FTP NAT prerecirc                   skipped (system-traffic.at:2852)
 61: conntrack - FTP NAT prerecirc seqadj            skipped (system-traffic.at:2863)
 62: conntrack - FTP NAT postrecirc                  skipped (system-traffic.at:2915)
 63: conntrack - FTP NAT postrecirc seqadj           skipped (system-traffic.at:2926)
 64: conntrack - IPv6 HTTP with NAT                  ok
 65: conntrack - IPv6 FTP with NAT                   skipped (system-traffic.at:2972)
 66: conntrack - DNAT load balancing                 ok
 67: conntrack - DNAT load balancing with NC         ok

802.1ad

 68: 802.1ad - vlan_limit                            ok
 69: 802.1ad - push/pop outer 802.1ad                ok
 70: 802.1ad - push/pop outer 802.1q                 ok
 71: 802.1ad - 802.1q tunnel                         ok

system-ovn

 72: ovn -- 2 LRs connected via LS, gateway router, SNAT and DNAT ok
 73: ovn -- 2 LRs connected via LS, gateway router, easy SNAT ok
 74: ovn -- multiple gateway routers, SNAT and DNAT  ok
 75: ovn -- load-balancing                           ok
 76: ovn -- load-balancing - same subnet.            ok
 77: ovn -- load balancing in gateway router         ok
 78: ovn -- multiple gateway routers, load-balancing ok
 79: ovn -- DNAT and SNAT on distributed router - N/S ok
 80: ovn -- DNAT and SNAT on distributed router - E/W ok

## ------------- ##
## Test results. ##
## ------------- ##

ERROR: 71 tests were run,
1 failed unexpectedly.
9 tests were skipped.



Version-Release number of selected component (if applicable):

openvswitch-2.7.0-8.git20170530.el7fdb.src.rpm

How reproducible: 100%


Steps to Reproduce:
1. rpmbuild --rebuild --with check_datapath_kernel openvswitch-2.7.0-8.git20170530.el7fdb.src.rpm
2.
3.

Actual results:
54: conntrack - SNAT with ct_mark change on reply   FAILED (system-traffic.at:2470)

Expected results:
PASS

Additional info:
Comment 1 Eric Garver 2017-06-27 08:49:23 EDT

*** This bug has been marked as a duplicate of bug 1457439 ***

Note You need to log in before you can comment on or make changes to this bug.