Bug 1465346 - [Regression] Search on Topology page is broken
[Regression] Search on Topology page is broken
Status: CLOSED CURRENTRELEASE
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.8.0
Unspecified Unspecified
high Severity high
: GA
: 5.8.1
Assigned To: Dávid Halász
Nandini Chandra
ui:search:topology
: Regression, TestOnly
: 1466416 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-27 05:26 EDT by Nandini Chandra
Modified: 2017-09-13 15:23 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.8.1.2
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-24 12:50:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core


Attachments (Terms of Use)

  None (edit)
Description Nandini Chandra 2017-06-27 05:26:35 EDT
Description of problem:
----------------------
Search on Topology page is not working anymore.This used to work in 
5.8.0.17(GA).

Also tested 5.7.3.2 and it works fines.



Version-Release number of selected component (if applicable):
--------------------------------------------------------------
5.8.1


How reproducible:
----------------
Always


Steps to Reproduce:
-------------------
1.Manage a provider.Navigate to its Topology page.
2.Enter a string in the Search box.Hit Enter or click mouse.



Actual results:
---------------
Search doesn't return any results even if there is a match.


Expected results:
-----------------
Search should return results.


Additional info:
----------------
Comment 2 Dávid Halász 2017-07-07 07:44:38 EDT
*** Bug 1466416 has been marked as a duplicate of this bug. ***
Comment 5 CFME Bot 2017-07-11 09:37:51 EDT
New commit detected on ManageIQ/manageiq-ui-classic/fine:
https://github.com/ManageIQ/manageiq-ui-classic/commit/6acb87b9758829557cb6043c3a7f55ec5ecbf74b

commit 6acb87b9758829557cb6043c3a7f55ec5ecbf74b
Author:     Dávid Halász <dhalasz@redhat.com>
AuthorDate: Fri Jul 7 13:47:34 2017 +0200
Commit:     Dávid Halász <dhalasz@redhat.com>
CommitDate: Fri Jul 7 14:11:43 2017 +0200

    Fix search on the topology screens
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1465346

 .../controllers/cloud_topology/cloud_topology_controller.js           | 2 ++
 .../controllers/container_topology/container_topology_controller.js   | 1 +
 .../controllers/infra_topology/infra_topology_controller.js           | 2 ++
 .../controllers/middleware_topology/middleware_topology_controller.js | 4 +++-
 .../controllers/network_topology/network_topology_controller.js       | 2 ++
 .../physical_infra_topology/physical_infra_topology_controller.js     | 2 ++
 app/assets/javascripts/services/topology_service.js                   | 4 ++--
 7 files changed, 14 insertions(+), 3 deletions(-)
Comment 6 Nandini Chandra 2017-07-13 00:21:52 EDT
Verified in  5.8.1.2

Note You need to log in before you can comment on or make changes to this bug.