Bug 1465399 - [RFE] repoquery should support a query Exclusivearch and ExcludeArch tag
[RFE] repoquery should support a query Exclusivearch and ExcludeArch tag
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
rawhide
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
: Documentation, FutureFeature, Triaged, UserExperience
Depends On: 1361617
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-27 07:59 EDT by Sergio Monteiro Basto
Modified: 2017-06-27 08:01 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1361617
Environment:
Last Closed: 2017-06-27 08:01:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergio Monteiro Basto 2017-06-27 07:59:32 EDT
+++ This bug was initially created as a clone of Bug #1361617 +++

Description of problem:
It would be nice to have an option for dnf repoquery, that would list all packages which require a given package during build.

--- Additional comment from Jaroslav Škarvada on 2016-07-29 15:20:58 WEST ---

I.e. alias for:
 dnf repoquery --disablerepo=\* --enablerepo=SRC --arch=src --whatrequires PKG

--- Additional comment from Jaroslav Škarvada on 2016-07-29 15:23:18 WEST ---

I could be called --whatbuildrequires, etc.

The above example is not straightforward and it is not easy to find it. At least it should be present in the dnf.plugin.repoquery manual page examples.

--- Additional comment from Igor Gnatenko on 2016-07-29 15:25:35 WEST ---

$ dnf repoquery --repo=fedora-rawhide --arch src --whatrequires PKG

in DNF 2.0, but agree that it should be documented.

--- Additional comment from Tomas Orsava on 2017-01-25 16:34:21 WET ---

Update, this works on dnf 1.1.10:

$ dnf repoquery --disablerepo=\* --enablerepo=rawhide-source --arch=src --whatrequires PKG

--- Additional comment from Sergio Monteiro Basto on 2017-03-18 19:43:43 WET ---

and about query Exclusivearch tag ?
Comment 1 Igor Gnatenko 2017-06-27 08:01:22 EDT
Please, open new bug instead of cloning.

Note You need to log in before you can comment on or make changes to this bug.