Bug 1465444 - [RFE] Exporting Content View Versions needs clarification
[RFE] Exporting Content View Versions needs clarification
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Content Management Guide (Show other bugs)
Unspecified
Unspecified Unspecified
medium Severity medium (vote)
: Beta
: 6.X
Assigned To: Sergei Petrosian
Stephen Wadeley
: FutureFeature
Depends On:
Blocks: 1455785
  Show dependency treegraph
 
Reported: 2017-06-27 08:48 EDT by Stephen Wadeley
Modified: 2017-11-06 06:46 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-12 12:48:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Wadeley 2017-06-27 08:48:53 EDT
Document URL: 

https://access.redhat.com/documentation/en-us/red_hat_satellite/6.2/html/content_management_guide/using_iss#exporting_content_view_versions_cvvs_to_a_directory

Section Number and Name: 

Exporting Content View Versions (CVVs) to a Directory

Describe the issue: 

Re: tree megacorp-cdn_megacorp_com-v1.0

The tree command is not installed by default.

You cannot just show that command without mentioning that you need the full path to the CV you just exported.

Re: Create a symbolic link to the version directory and then use the link:
That command will not work without the full path

Re: When you configure a subscription CDN URL to point to where the export is being served from, use the symbolic link:

The `hammer organization update` command needs to be entered on the downstream (importing) server, not the exporting server. But that is not explained.


Suggestions for improvement: 

Test the procedure and fix the descriptions so that it works as described.

Additional information: 

Re: To Determine Which Content View Version to Export and "cdn.megacorp.com"
I think we are not supposed to make up names

Minor markup issue:

# hammer repository export --id 1 [--export-to-iso 1]  --since [ ISO_Date ]

the ISO_Date should not be in [] as its not optional, its a replaceable.
Comment 1 Andrew Dahms 2017-07-13 01:40:30 EDT
Assigning to Sergei for review.
Comment 25 Sergei Petrosian 2017-10-12 12:48:16 EDT
I merged this branch into master.

Thank you
Comment 26 Sergei Petrosian 2017-10-17 11:47:04 EDT
I pushed the latest changes into the 6.2 branch

Thank you

Note You need to log in before you can comment on or make changes to this bug.