Bug 1465578 - conflict with gstreamer1-plugins-ugly during upgrade
conflict with gstreamer1-plugins-ugly during upgrade
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: gstreamer1-plugins-ugly-free (Show other bugs)
25
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Yaakov Selkowitz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-27 12:33 EDT by Przemek Klosowski
Modified: 2017-12-12 05:30 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-12 05:30:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Przemek Klosowski 2017-06-27 12:33:59 EDT
Description of problem:
I had previously installed
gstreamer1-plugins-ugly-1.10.4-3.fc25.x86_64       rpmfusion-free-updates 
gstreamer1-plugins-ugly-free-1.10.4-3.fc25.x86_64  updates

and the update to 1.10.5-1.fc25 errors out


Version-Release number of selected component (if applicable):
gstreamer1-plugins-ugly-1.10.4-3.fc25.x86_64       rpmfusion-free-updates 
gstreamer1-plugins-ugly-free-1.10.4-3.fc25.x86_64  updates

How reproducible: every time

Steps to Reproduce:
1. dnf update --best

Actual results:
Last metadata expiration check: 1:51:47 ago on Tue Jun 27 10:11:10 2017.
Error: package gstreamer1-plugins-ugly-1.10.4-3.fc25.x86_64 requires gstreamer1-plugins-ugly-free(x86-64) = 1.10.4, but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)


Expected results: successful update
Comment 1 Przemek Klosowski 2017-06-27 12:37:16 EDT
I erased both packages and tried to reinstall, and got file conflicts, so I think that the rpmfusion package (g-p-ugly) was replaced by the regular repo (g-p-ugly-free). I think the issue is solved by deleting the rpmfusion package and/or reinstalling the regular one.
Comment 2 Yaakov Selkowitz 2017-06-27 13:05:59 EDT
(In reply to Przemek Klosowski from comment #1)
> I erased both packages and tried to reinstall, and got file conflicts, so I
> think that the rpmfusion package (g-p-ugly) was replaced by the regular repo
> (g-p-ugly-free).

Only partially; there are still some parts that are in -ugly that can't (yet) be in -ugly-free.  This was coordinated with rpmfusion, but IIUC the non-conflicting -ugly for F25 may still be stuck in testing.
Comment 3 Fedora End Of Life 2017-11-16 14:00:50 EST
This message is a reminder that Fedora 25 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 25. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '25'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 25 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.
Comment 4 Fedora End Of Life 2017-12-12 05:30:57 EST
Fedora 25 changed to end-of-life (EOL) status on 2017-12-12. Fedora 25 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.