Bug 146567 - [RFE] dump is unable to store EA/ACL
[RFE] dump is unable to store EA/ACL
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: dump (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
http://dump.sourceforge.net
:
: 153710 166007 (view as bug list)
Depends On:
Blocks: 156322
  Show dependency treegraph
 
Reported: 2005-01-29 14:17 EST by Milan Kerslager
Modified: 2013-07-02 19:05 EDT (History)
8 users (show)

See Also:
Fixed In Version: RHBA-2005-359
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 09:42:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2005-01-29 14:17:49 EST
Current version of dump is dump-0.4b37-1 (RHEL4 Beta 2). With this
tool we are unable to store EA/ACL (on ext3). This is very bad as
there should be a possibility to backup FS with ACL (ACL is the
standad extension since RHEL3). We have snapshot support with LVM2 so
go ahead to be really enterprise!
Comment 1 Jindrich Novy 2005-01-30 06:36:00 EST
Please note that support for extended attributes and access control
lists is still in experimental state so it couldn't be included
sooner. The recent development package is dump-0.4b39-1 with EA/ACL
patch included. You can use this package for now to use the
functionality. The experimetal patch is to be applied officially in
stable release since dump-0.4b40.
Comment 2 Milan Kerslager 2005-01-30 07:34:34 EST
The bug has been meant as RFE for RHEL4 U1 or so.
Comment 3 L3support 2005-02-07 19:46:06 EST
We want dump-0.4b39-1 or dump-0.4b40 for RHEL4-GA.

[Actual Result]
"ACLs in inode #? won't be dumped" repeated over 2000 times !!!

# rpm -qa dump
dump-0.4b37-1
# dump 0uf /tmp/test.dump /dev/sda4
  DUMP: Date of this level 0 dump: Mon Feb  7 18:04:12 2005
  DUMP: Dumping /dev/sda4 (/var) to /tmp/test.dump
  DUMP: Label: /var1
  DUMP: Writing 10 Kilobyte records
  DUMP: mapping (Pass I) [regular files]
  DUMP: mapping (Pass II) [directories]
  DUMP: estimated 3305523 blocks.
  DUMP: Volume 1 started with block 1 at: Mon Feb  7 18:04:19 2005
  DUMP: dumping (Pass III) [directories]
  DUMP: ACLs in inode #2 won't be dumped
  DUMP: ACLs in inode #65537 won't be dumped
  DUMP: ACLs in inode #65538 won't be dumped
  DUMP: ACLs in inode #65539 won't be dumped
  DUMP: ACLs in inode #65540 won't be dumped
  DUMP: ACLs in inode #65541 won't be dumped
  (omitted)  repeated 2000 times !!!
  DUMP: Closing /tmp/test.dump
  DUMP: Volume 1 completed at: Mon Feb  7 18:06:30 2005
  DUMP: Volume 1 3305070 blocks (3227.61MB)
  DUMP: Volume 1 took 0:02:11
  DUMP: Volume 1 transfer rate: 25229 kB/s
  DUMP: 3305070 blocks (3227.61MB) on 1 volume(s)
  DUMP: finished in 131 seconds, throughput 25229 kBytes/sec
  DUMP: Date of this level 0 dump: Mon Feb  7 18:04:12 2005
  DUMP: Date this dump completed:  Mon Feb  7 18:06:30 2005
  DUMP: Average transfer rate: 25229 kB/s
  DUMP: DUMP IS DONE

[Expected Result]
# rpm -qa dump
dump-0.4b39-1
# dump 0uf /tmp/test.dump /dev/sda4
  DUMP: Date of this level 0 dump: Mon Feb  7 17:56:03 2005
  DUMP: Dumping /dev/sda4 (/var) to /tmp/test.dump
  DUMP: Label: /var1
  DUMP: Writing 10 Kilobyte records
  DUMP: mapping (Pass I) [regular files]
  DUMP: mapping (Pass II) [directories]
  DUMP: estimated 3305514 blocks.
  DUMP: Volume 1 started with block 1 at: Mon Feb  7 17:56:10 2005
  DUMP: dumping (Pass III) [directories]
  DUMP: dumping (Pass IV) [regular files]
  DUMP: Closing /tmp/test.dump
  DUMP: Volume 1 completed at: Mon Feb  7 17:58:25 2005
  DUMP: Volume 1 3315050 blocks (3237.35MB)
  DUMP: Volume 1 took 0:02:15
  DUMP: Volume 1 transfer rate: 24555 kB/s
  DUMP: 3315050 blocks (3237.35MB) on 1 volume(s)
  DUMP: finished in 135 seconds, throughput 24555 kBytes/sec
  DUMP: Date of this level 0 dump: Mon Feb  7 17:56:03 2005
  DUMP: Date this dump completed:  Mon Feb  7 17:58:25 2005
  DUMP: Average transfer rate: 24555 kB/s
  DUMP: DUMP IS DONE
  
Comment 4 Jindrich Novy 2005-02-08 02:10:22 EST
Please see comment #1 why it's not possible at the moment. Furthermore
it's too late to build anything to RHEL4-0day, because it's locked for
about two weeks now.
Comment 5 Jindrich Novy 2005-02-18 09:57:30 EST
Please note the discussion related to dump-0.4b39 on x86_64 in bug 147710.
Comment 6 Jindrich Novy 2005-02-28 11:59:02 EST
dump-0.4b39-2 is now built in rawhide with support for in-inode EAs
when using recent kernels and big inodes. For details please see bug
149299.
Comment 7 Jindrich Novy 2005-04-05 09:35:18 EDT
*** Bug 153710 has been marked as a duplicate of this bug. ***
Comment 10 Jindrich Novy 2005-04-06 01:27:57 EDT
The dump erratum is now created.
Comment 21 Ben Levenson 2005-08-15 17:29:37 EDT
*** Bug 166007 has been marked as a duplicate of this bug. ***
Comment 22 Red Hat Bugzilla 2005-10-05 09:42:21 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-359.html

Note You need to log in before you can comment on or make changes to this bug.