Bug 1465671 - Can't install LibreOffice build dependencies
Can't install LibreOffice build dependencies
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: releng (Show other bugs)
7.3
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Lubos Kocman
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-27 18:28 EDT by Ahmad Hussein
Modified: 2017-07-31 14:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-06 08:38:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"yum-builddep libreoffice" output (133.47 KB, text/plain)
2017-06-27 18:28 EDT, Ahmad Hussein
no flags Details

  None (edit)
Description Ahmad Hussein 2017-06-27 18:28:02 EDT
Created attachment 1292477 [details]
"yum-builddep libreoffice" output

"# yum-builddep libreoffice" produce error messages such as the following:

---------------------------------
Error: Package: liborcus-devel-0.5.1-7.el7.x86_64 (rhel-7-server-optional-rpms)
           Requires: liborcus(x86-64) = 0.5.1-7.el7
           Available: liborcus-0.5.1-7.el7.x86_64 (rhel-7-server-optional-rpms)
               liborcus(x86-64) = 0.5.1-7.el7
           Installing: liborcus-0.7.0-6.el7.x86_64 (rhel-7-server-optional-rpms)
               liborcus(x86-64) = 0.7.0-6.el7
---------------------------------


yum-builddep output is attached.
Comment 2 David Tardon 2017-06-28 03:54:17 EDT
Your source repositories contain 12 libreoffice source RPMs, ranging from 4.0.x to 5.0.x. So yum-builddep is trying to install build deps for all of them. There is about a dozen libs for which it tries to install 2 or more conflicting versions at once; liborcus is just one of these.

"yum clean metadata --enablerepo=*" might help. If it doesn't, the problem is in the source repositories you have enabled. I very much doubt you're using the official ones, but I'll leave this open for now...
Comment 3 Ahmad Hussein 2017-06-28 09:17:58 EDT
(In reply to David Tardon from comment #2)
> Your source repositories contain 12 libreoffice source RPMs, ranging from
> 4.0.x to 5.0.x. So yum-builddep is trying to install build deps for all of
> them. There is about a dozen libs for which it tries to install 2 or more
> conflicting versions at once; liborcus is just one of these.
> 
> "yum clean metadata --enablerepo=*" might help. If it doesn't, the problem
> is in the source repositories you have enabled. I very much doubt you're
> using the official ones, but I'll leave this open for now...

Thank you Tardon,

Unfortunately "yum clean metadata --enablerepo=*" didn't work.
The output of "yum repolist enabled":

---------------------------------
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
              : manager
repo id                                    repo name                      status
rhel-7-server-optional-rpms/7Server/x86_64 Red Hat Enterprise Linux 7 Ser 11015
rhel-7-server-rpms/7Server/x86_64          Red Hat Enterprise Linux 7 Ser 14476
repolist: 25491
---------------------------------

Isn't rhel-7-server-optional the right repository?
Comment 4 Ahmad Hussein 2017-06-28 21:32:53 EDT
> Your source repositories contain 12 libreoffice source RPMs, ranging from
> 4.0.x to 5.0.x. So yum-builddep is trying to install build deps for all of
> them.

Specifying libreoffice version fixed the issue, thank you.

But isn't this a bug (latest version should be installed by default)? or I was doing something wrong?
Comment 6 Red Hat Bugzilla Rules Engine 2017-07-06 08:38:35 EDT
Development Management has reviewed and declined this request. You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.