Bug 1465680 - [abrt] cinnamon: get_settings(): JsonSettingsWidgets.py:119:get_settings:FileNotFoundError: [Errno 2] File o directory non esistente: '/home/fedorauser/.cinnamon/configs/bbcwx@oak-wood.co.uk/4.json'
[abrt] cinnamon: get_settings(): JsonSettingsWidgets.py:119:get_settings:File...
Status: CLOSED DUPLICATE of bug 1452945
Product: Fedora
Classification: Fedora
Component: cinnamon (Show other bugs)
26
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:b121bf520e9835ba1e091f5298d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-27 19:20 EDT by xzj8b3
Modified: 2017-06-28 01:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-28 01:40:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (713 bytes, text/plain)
2017-06-27 19:20 EDT, xzj8b3
no flags Details
File: cgroup (289 bytes, text/plain)
2017-06-27 19:20 EDT, xzj8b3
no flags Details
File: cpuinfo (1.20 KB, text/plain)
2017-06-27 19:20 EDT, xzj8b3
no flags Details
File: environ (1.66 KB, text/plain)
2017-06-27 19:20 EDT, xzj8b3
no flags Details
File: mountinfo (3.72 KB, text/plain)
2017-06-27 19:20 EDT, xzj8b3
no flags Details
File: namespaces (102 bytes, text/plain)
2017-06-27 19:20 EDT, xzj8b3
no flags Details
File: open_fds (1.17 KB, text/plain)
2017-06-27 19:20 EDT, xzj8b3
no flags Details

  None (edit)
Description xzj8b3 2017-06-27 19:20:05 EDT
Version-Release number of selected component:
cinnamon-3.4.2-1.fc26

Additional info:
reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/share/cinnamon/cinnamon-settings/xlet-settings.py desklet bbcwx@oak-wood.co.uk 4
crash_function: get_settings
exception_type: FileNotFoundError
executable:     /usr/share/cinnamon/cinnamon-settings/xlet-settings.py
kernel:         4.11.6-301.fc26.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
JsonSettingsWidgets.py:119:get_settings:FileNotFoundError: [Errno 2] File o directory non esistente: '/home/fedorauser/.cinnamon/configs/bbcwx@oak-wood.co.uk/4.json'

Traceback (most recent call last):
  File "/usr/share/cinnamon/cinnamon-settings/bin/JsonSettingsWidgets.py", line 104, in check_settings
    self.settings = self.get_settings()
  File "/usr/share/cinnamon/cinnamon-settings/bin/JsonSettingsWidgets.py", line 119, in get_settings
    file = open(self.filepath)
FileNotFoundError: [Errno 2] File o directory non esistente: '/home/fedorauser/.cinnamon/configs/bbcwx@oak-wood.co.uk/4.json'

Local variables in innermost frame:
self: <JsonSettingsWidgets.JSONSettingsHandler object at 0x7f5febabbf98>
Comment 1 xzj8b3 2017-06-27 19:20:11 EDT
Created attachment 1292499 [details]
File: backtrace
Comment 2 xzj8b3 2017-06-27 19:20:12 EDT
Created attachment 1292500 [details]
File: cgroup
Comment 3 xzj8b3 2017-06-27 19:20:14 EDT
Created attachment 1292501 [details]
File: cpuinfo
Comment 4 xzj8b3 2017-06-27 19:20:15 EDT
Created attachment 1292502 [details]
File: environ
Comment 5 xzj8b3 2017-06-27 19:20:17 EDT
Created attachment 1292503 [details]
File: mountinfo
Comment 6 xzj8b3 2017-06-27 19:20:18 EDT
Created attachment 1292504 [details]
File: namespaces
Comment 7 xzj8b3 2017-06-27 19:20:20 EDT
Created attachment 1292505 [details]
File: open_fds
Comment 8 leigh scott 2017-06-28 01:40:10 EDT

*** This bug has been marked as a duplicate of bug 1452945 ***

Note You need to log in before you can comment on or make changes to this bug.